perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Bozrikov <b...@fgm.com.cy>
Subject mod_perl2 1.99_14 and httpd 2.0.49 - gmake test fails (cannot start apache)
Date Fri, 23 Jul 2004 13:11:16 GMT
Good day or whatever it is at your location,

1. Problem description

couple  of days ago I have compiled and (to the extent of my competency)
tested  Apache  httpd 2.0.49 on powerpc-aix-5.1.0.0 platform (IBM RS6000
7009  C10  model).  Now  trying  to compile mod_perl 1.99_14. Everything
seems  to compile and build fine, but when I'm doing 'gmake test', seems
httpd won't start properly:

following is the screen log:
$ t/TEST -verbose compat/apache_util.t modperl/pnotes.t
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/local/bin/perl /home/bozy/src/mod_perl-1.99_14/t/TEST -verbose 'compat/apache_util.t'
'modperl/pnotes.t'
/usr/local/apache2/bin/httpd -d /home/bozy/src/mod_perl-1.99_14/t -f /home/bozy/src/mod_perl-1.99_14/t/conf/httpd.conf
-D APACHE2 
using Apache/2.0.49 (prefork MPM)

waiting 120 seconds for server to start: .............[Fri Jul 23 09:47:36 2004] [info] 28
Apache:: modules loaded
[Fri Jul 23 09:47:36 2004] [info] 5 APR:: modules loaded
[Fri Jul 23 09:47:36 2004] [info] base server + 17 vhosts ready to run tests
.............................................................................................................
waiting 120 seconds for server to start: not ok
[  error] giving up after 121 secs. If you think that your system
is slow or overloaded try again with a longer timeout value.
by setting the environment variable APACHE_TEST_STARTUP_TIMEOUT
to a high value (e.g. 420) and repeat the last command.

[  error] server failed to start! (please examine t/logs/error_log)
$

I  am sure there is enough time to start httpd, I tried with 400 and 600
seconds delay wait. httpd seems to exit silently. there is enough ulimit
to produce core file. No core file being produced.

t/logs/error_log shows no signs of any serious errors:

[quote]
END in modperl_extra.pl, pid=7562
[Fri Jul 23 09:47:59 2004] [info] 28 Apache:: modules loaded
[Fri Jul 23 09:47:59 2004] [info] 5 APR:: modules loaded
[Fri Jul 23 09:47:59 2004] [info] base server + 5 vhosts ready to run tests
[unquote]

2. Used Components and their Configuration:

*** mod_perl version 1.9914

*** using lib/Apache/BuildConfig.pm
*** Makefile.PL options:
  MP_AP_PREFIX   => /usr/local/apache2
  MP_COMPAT_1X   => 1
  MP_GENERATE_XS => 1
  MP_LIBNAME     => mod_perl
  MP_USE_DSO     => 1
  MP_USE_STATIC  => 1


*** /usr/local/apache2/bin/httpd -V
Server version: Apache/2.0.49
Server built:   Jul 15 2004 12:00:32
Server's Module Magic Number: 20020903:7
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"


!!!NOTICE!!!: Apache has PHP 5.0 as a DSO module - maybe this could give
a clue (but NOT loading PHP does not help). PHP and MySQL interface runs
just fine with Apache - tested on several rather simple applications.

*** /usr/local/bin/perl -V
Summary of my perl5 (revision 5 version 8 subversion 4) configuration:
  Platform:
    osname=aix, osvers=5.1.0.0, archname=aix
    uname='aix powerpc 1 5 002001444800 '
    config_args='-Dcc=gcc'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='gcc', ccflags ='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -DUSE_NATIVE_DLOPEN
-fno-strict-aliasing -I/usr/local/include -D_LARGE_FILES',
    optimize='-O',
    cppflags='-D_ALL_SOURCE -D_ANSI_C_SOURCE -D_POSIX_SOURCE -DUSE_NATIVE_DLOPEN -fno-strict-aliasing
-I/usr/local/include'
    ccversion='', gccversion='3.3.3', gccosandvers='aix5.1.0.0'
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='gcc', ldflags =' -Wl,-brtl -L/usr/local/lib -Wl,-b32'
    libpth=/usr/local/lib /lib /usr/lib /usr/ccs/lib /usr/local/apache2/lib
    libs=-lbind -lnsl -ldbm -ldl -lld -lm -lcrypt -lc -lbsd
    perllibs=-lbind -lnsl -ldl -lld -lm -lcrypt -lc -lbsd
    libc=/lib/libc.a, so=a, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_aix.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Xlinker -bE:/usr/local/lib/perl5/5.8.4/aix/CORE/perl.exp'
    cccdlflags=' ', lddlflags='  -Wl,-bhalt:4 -Wl,-bM:SRE -Wl,-bI:$(PERL_INC)/perl.exp -Wl,-bE:$(BASEEXT).exp
-Wl,-bnoentry -lc -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: USE_LARGE_FILES
  Built under aix
  Compiled at Jul 18 2004 00:19:56
  %ENV:
    PERL_LWP_USE_HTTP_10="1"
  @INC:
    /usr/local/lib/perl5/5.8.4/aix
    /usr/local/lib/perl5/5.8.4
    /usr/local/lib/perl5/site_perl/5.8.4/aix
    /usr/local/lib/perl5/site_perl/5.8.4
    /usr/local/lib/perl5/site_perl
    .

*** Packages of interest status:

Apache::Request: -
CGI            : 3.04
LWP            : -
mod_perl       : -


I am not a programmer myself, so I did not investigate further, just
tried to find similar cases on the Net, but did not find a close match
yet.


Regards,


Alexey



** Life's biggest question is whether or not you're happy - not with others, but with yourself.


-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message