perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: make test hangs
Date Thu, 06 May 2004 05:09:52 GMT
William Fulmer wrote:
>>Ouch, William, are you aware that you've sent a 1MB attachment to 
>>a public mailing list, potentially causing lots of problems to people
>>with limited account sizes and slow dialup access? Please don't that 
>>in the future. If you want to show some big file, upload it 
>>somewhere and post a link to it.
> 
> 
> Sorry.  I didn't look at the size before I sent it.  Will be more
> carefull in the future.  

Cool!

> The end of your trace is:
> 
> 
> open("/usr/lib/nls/loc/locales.2/C", O_RDONLY, 0) 
> .................................. ERR#2 ENOENT
> time(0x7f71cd0c) 
> ................................................................... =
> 1083792204
> sigsetstatemask(0x17, NULL, 2139033120) 
> ............................................ = 0
> write(2, "N o   - M   a l l o w e d   w h ".., 36) 

Aha! It says -M is not allowed. (stat __FILE__)[9]; is the same as

   -M __FILE__

> write(2, "p e r l _ p a r s e :   N o   s ".., 38) 

this perl_parse() thing is interesting. It writes to STDERR that perl_parse() 
has failed. BTW, any difference if you change your code to be:

my $file = "/tmp";
my $mtime = (stat $file)[9];

and:

my $file = __FILE__;
my $mtime = (stat $file)[9];

and:

-M __FILE__;

and

-M "/tmp";


> 
>>but I see that the process is exiting. Is it still hanging? Or is it
> 
> the 
> 
>>client process?
> 
> 
> Yes it did exit when I ran it this way.  May be a fluke with my compile
> of tusc however.  When I run it without the tusc comand (ie
> "/usr/opt/httpd-2.0.49/bin/httpd -d t -f conf/httpd.conf  -DAPACHE2
> -DONE_PROCESS -DNO_DETATCH") it hangs.  Helpful of it, yes?

It's possible. I've seen processes exiting when attaching to or detaching from 
them with strace. another way to check where the process is hanging is to 
attach to it with gdb (using -p $pid) and then run 'bt'.

>>I see that you also run with mod_perl tracing enabled, you may want 
>>to turn it off to make the strace output smaller.
> 
> 
> I'll do that in the morning.  It may help for me to mention that I'm
> using HP's ANSI C compiler for the compiles.  The version is quite old
> (enough so that I cannot apply the patches listed on the troubleshooting
> web page).  May be a useful exercise to update my compiler and try
> again.  May take a while as I have to Weedle "CODEWORDS" out of HP
> support to accomplish this.  Let me also say that I was able to compile
> and run mod_perl-1.99_12 with this same install of apache and an install
> of perl 5.8.2 with the same basic config options as my perl 5.6.2.  I
> think I'll try compiling this version with the 5.8.2 perl and see if
> that works better. 

What's important is that you compile perl, apache and mod_perl with the same 
compiler. Though I'm not familiar with HP's ANSI C compiler, so it's possible 
that it's a problem there.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message