perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: mp2 static build on HPUX11i: tests
Date Tue, 04 May 2004 17:38:12 GMT

> Here are the results you asked for :
> 
> t/TEST -clean
> t/TEST -v t/api/module.t t/apr/netlib.t t/compat/conn_rec.t 
> t/modperl/setupenv.t  t/preconnection/note.t

Thanks. So it all comes down to two issues.

1) Apache::Module::loaded('mod_perl.so')

> t/api/module............1..11
> # testing : Apache::Module::loaded('mod_perl.so')
> # expected: 1
> # received: 0
> not ok 6

It makes sense that mod_perl.so is not loaded, since it doesn't exist. 
Philippe, I wonder how this test has passed for you.

2) the rest of the tests fail on $ENV{REMOTE_ADDR} and $r->remote_address 
returning 0.0.0.0 instead of 127.0.0.1. Sounds like an ipv6 issue to me. but 
since all those running ipv6 didn't report that problem that sounds as either 
a bug in Apache on HPUX11i or some OS issues. Olivier, could you try a mod_cgi 
script that prints out  $ENV{REMOTE_ADDR}, when your client is running on the 
same machine and when it's running from another machine? Thanks.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message