perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bram Whillock" <b...@cmu.edu>
Subject RE: PerlRun, nothing but page header
Date Mon, 05 Apr 2004 21:21:09 GMT
Getting rid of the fatalsToBrowser does nothing.

The second script gives me an error:
[Mon Apr  5 14:17:15 2004] [error] PerlRun: `Can't call method
"send_http_header" on an undefined value at /var/www/beta/modperl.cgi
line 3.

> -----Original Message-----
> From: Stas Bekman [mailto:stas@stason.org]
> Sent: Monday, April 05, 2004 5:15 PM
> To: Bram Whillock
> Cc: modperl@perl.apache.org
> Subject: Re: PerlRun, nothing but page header
> 
> Bram Whillock wrote:
> > I recently built and got up and running apache 1.3.19 with mod_perl
and
> > mod_ssl.  I'm not receiving any error messages, but I cannot get any
> > output from a test page.
> 
> Any difference if you remove this line?
> 
>    use CGI::Carp qw(fatalsToBrowser);
> 
> If not, any luck with this script:
> 
> #!/usr/bin/perl
> my $r = shift;
> $r->send_http_header("text/html");
> $r->print("<html><body>Hello</body></html>");
> 
> __________________________________________________________________
> Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
> http://stason.org/     mod_perl Guide ---> http://perl.apache.org
> mailto:stas@stason.org http://use.perl.org http://apacheweek.com
> http://modperlbook.org http://apache.org   http://ticketmaster.com



-- 
Report problems: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html
List etiquette: http://perl.apache.org/maillist/email-etiquette.html


Mime
View raw message