perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Modperl 2.0 Not finding correct *.conf
Date Tue, 20 Jan 2004 01:23:10 GMT
steve larson wrote:
>  Hello,
>   at this point, I have started from scratch with a
> new
> Perl 5.8.2, and then rebuilt the modperl 2.0, with new
> source, source tree.
> 
> I may still be missing some parts.
> 
> Herein contains the error outputs from the make test.
> 
> If you believe these are OK, then I would go on
> to the make install step - I hesitate as things do not
> look proper.

The good news is that you can now run 'make install'. Though first I'd advise 
to satisfy the prerequisites, such as LWP and CGI and run 'make test' again, 
because at the moment quite a few tests weren't run.

The only problem in failing apr-ext/perlio is not a modperl problem. apr-ext 
tests the APR:: perl glue outside modperl, which most likely you aren't going 
to use now. so you can ignore it.

Though let's try to see why it still fails, after we have spent so much time 
on it and nail it down.

> apr-ext/perlio....................skipped
>         all skipped: This test is under construction
> apr-ext/uuid......................Can't load
> '/usr/local/source/modperl-2.0/t/../blib/arch/Apache2/auto/APR/APR.so'
> for module APR:
> /usr/local/source/modperl-2.0/t/../blib/arch/Apache2/auto/APR/APR.so:
> undefined symbol: apr_hook_global_pool at
> /usr/local/lib/perl5/5.8.2/i686-linux-thread-multi/DynaLoader.pm
> line 229.
>  at apr-ext/uuid.t line 25
> Compilation failed in require at apr-ext/uuid.t line
> 25.
> apr-ext/uuid......................dubious
>         Test returned status 255 (wstat 65280, 0xff00)
> DIED. FAILED tests 1-3
>         Failed 3/3 tests, 0.00% okay

what happens if you rebuild mod_perl as you did now, but adding:
MP_APR_CONFIG=/usr/local/apache2/httpd/prefork/bin/apr-config
You do have /usr/local/apache2/httpd/prefork/bin/apr-config, right?

I wan't to see the output of:

/usr/local/apache2/httpd/prefork/bin/apr-config --link-ld --libs

Also tell me where your libapr-0.so.0.9.5 or libapr-0.so is

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


-- 
Reporting bugs: http://perl.apache.org/bugs/
Mail list info: http://perl.apache.org/maillist/modperl.html


Mime
View raw message