perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McLean, Grant" <grant.mcl...@bearingpoint.com>
Subject RE: [mp2] Module naming
Date Thu, 01 May 2003 01:39:07 GMT
Perrin Harkins wrote:
> We are getting too many questions along the lines of 
> "I tried to run Apache::Foo on mod_perl 2 and it didn't work"
> for modules which no one has tried to port yet.  
> Or maybe we just need a document listing modules that have
> been ported.

A separate document sounds like a potential maintenance problem.

The POD or README for a module would seem to be a good place
for Apache module authors to declare their mod_perl version 
support.  That way people can tell from browsing search.cpan.org
whether something is expected to work before they even download
it.

Of course the default assumption at the moment should probably
be that if a module doesn't say which version of the mod_perl
API it was written to then it almost certainly only works with
the 1.0 API.  How we communicate to people that that should be
the default assumption is a tricky problem.

Regards
Grant

Mime
View raw message