perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Eisenschmidt <>
Subject Problem Building 1.99_08 on OpenBSD
Date Mon, 03 Feb 2003 15:02:27 GMT
OpenBSD 3.2
Perl 5.6.1

I'm trying to build MP 1.99_08 for Apache 2.0.44, and I'm not quite
sure where I'm messing up. Apache built fine, building the config for
MP went fine:
	jweisen@kaitain$ sudo perl Makefile.PL MP_AP_PREFIX=/usr/local/apache2


	*** mod_perl dso library will be built as
	*** mod_perl static library will be built as mod_perl.a
	*** You'll need to add the following to httpd.conf:
	***  LoadModule perl_module modules/

But the actual make doesn't go so well:

	jweisen@kaitain$ sudo make


	ranlib: Inappropriate file type or format
	*** Error code 1

	Stop in /usr/local/src/mod_perl-1.99_08/src/modules/perl (line 149 of
	*** Error code 1

	Stop in /usr/local/src/mod_perl-1.99_08 (line 459 of Makefile).

I dug back a couple months in the mailing lists and I'm not seeing
anything applicable. Any help would be appreciated.


John W. Eisenschmidt (

"If encryption is outlawed, then only outlaws will have encryption."

View raw message