perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mitchel, Jennifer (Jem)" <mitch...@lucent.com>
Subject error from my .htaccess file
Date Tue, 01 Oct 2002 21:40:49 GMT
Hello,

  I know very little about Apache or mod_perl and I'm really lost.

  I am running Apache 1.3.22 and mod_perl 1.21 on a Sun Solaris 2.6 machine.  I'm sure Apache
and mod_perl are running as I can successfully grab that out of $ENV{SERVER_SOFTWARE}.  I'm
using perl 5.005_03.
  
  I am trying use a .htaccess file to allow NT Authenitcation on a directory.  However, I
am getting a server error

  > Syntax error on line 6 of /web/content/askLucent/password-reset/.htaccess:
      > Invalid command 'PerlAuthenHandler', perhaps mis-spelled or defined by a
      > module not included in the server configuration


Here are the contents of my .htaccess file

<Limit GET POST>
AuthName "NT Domain\Login and Password"
AuthType Basic
#PerlSetVar NT_Controllers 'na02il0015dc00:na02il0015dc01'
PerlSetVar NT_Controllers 'na02il0015dc04:na02il0015dc01:NA02IL0015DC02'
PerlAuthenHandler Apache::AuthenN2
require valid-user
</Limit>

I found the following thread from this list: http://www.mail-archive.com/modperl@apache.org/msg29191.html
and I did rebuild using perl Makefile.PL EVERYTHING=1 which I confirmed did modify Apache,
however, I still get the exact same error.

 Does anyone have an idea of what else I should be looking for?

Thanks.
Jennifer

Mime
View raw message