perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ufuk Yuzereroglu" <u...@itamigo.com>
Subject Mason 1.05 + Apache::Session problem!
Date Mon, 09 Sep 2002 23:35:13 GMT
Hi

I am running a RedHat 7.3 server with kernel 2.4.18, Apache 1.3-26,  mod_perl 1.26-5 and Apache::Session
1.53 and HTML::Mason-1.05 modules. When I 
try to start apache i get the error message:

Starting httpd: Subroutine status_mason redefined at /usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache/Status.pm
line 50.

But the server starts and operates. This bug is said to be fixed in HTML::Mason-0.85 but as
you can see I still get it. BTW I have the same components and code piece running on RedHat
7.0, apache 1.3-2x, mod_perl and Apache::Session 1.53 an HTML::Mason-1.05 modules.

The other problem (and the main) is, on the same system I have an authentication/session information
structure on my website built using Apache::Session. I manage to log on with the right username
and password. Apache-Session file for the session is created under /tmp with owner as apache:apache
and file rights as 644. But when I try to access the submenus from the main one, after the
initial login process, the server acts as if it cannot read the session files and does not
grant me access. The strangest thing is that I can access the submenus after clicking on the
link for 2-3 times. The first 1 or 2 does not grant access, but the last one always seems
to work. This seems to me that apache cannot or does not read from the same Session file each
time.

Can anyone please help? Thanks.

UY

Mime
View raw message