perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tiller, Michiel" <Michiel_Til...@bmc.com>
Subject RE: solaris 2.6, mod_perl 1.27, apache 1.3.26, resulting server f ails
Date Thu, 01 Aug 2002 08:04:33 GMT

Hmm.. I have only this week compiled the exact same versions of Apache and
mod_perl on Solaris 2.6, without any problems. I'd suggest to get the latest
gcc from:
ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/gcc-3.1-sol26-sparc-local.g
z

And it won't hurt to renew zlib,ncurses and gdbm either while you're at it:
ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/zlib-1.1.4-sol26-sparc-loca
l.gz
ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/ncurses-5.2-sol26-sparc-loc
al.gz
ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/gdbm-1.8.0-sol26-sparc-loca
l.gz

Hope it helps.

Cheers,
Michiel


-----Original Message-----
From: John E. Mendenhall [mailto:jem@electriciti.com]
Sent: Wednesday, July 31, 2002 23:26
To: modperl@perl.apache.org
Subject: re: solaris 2.6, mod_perl 1.27, apache 1.3.26, resulting server
fails


I have compiled mod_perl 1.27 with apache 1.3.26 under perl 5.6.1, solaris
2.6.  When I run the make test, it fails with the following in the
error_log:

  [notice] Destruction->DESTROY called for $global_object
  Prototype mismatch: sub Socket::INADDR_ANY vs () at
/usr/local/lib/perl5/5.6.1/sun4-solaris/Socket.pm line 329.
  Prototype mismatch: sub Socket::INADDR_BROADCAST vs () at
/usr/local/lib/perl5/5.6.1/sun4-solaris/Socket.pm line 330.
  Prototype mismatch: sub Socket::INADDR_LOOPBACK vs () at
/usr/local/lib/perl5/5.6.1/sun4-solaris/Socket.pm line 331.
  Prototype mismatch: sub Socket::INADDR_LOOPBACK vs () at
/usr/local/lib/perl5/5.6.1/sun4-solaris/Socket.pm line 332.
  [Wed Jul 31 14:12:36 2002] [warn] [notice] child_init for process 10483,
report any problems to [no address given]

This might all be fine and good, but when the test tries to retrieve the
test.html document, the server immediately stops, with no other messages
anywhere.  If I start the httpd daemon separately from running the tests
(make start_httpd), it starts just fine.  If I attach a truss to the
single process (running under -X), then run the tests (make run_tests), I
get these errors:

------- truss log -------
# truss -p 10483
accept(16, 0xEFFFF8F0, 0xEFFFF8EC) (sleeping...)
accept(16, 0xEFFFF8F0, 0xEFFFF8EC)              = 3
fcntl(17, F_SETLKW64, 0x001994C8)               = 0
sigaction(SIGUSR1, 0xEFFFF730, 0xEFFFF830)      = 0
getsockname(3, 0xEFFFF900, 0xEFFFF8EC)          = 0
setsockopt(3, 6, 1, 0xEFFFF86C, 4)              = 0
brk(0x006E9000)                                 = 0
brk(0x006EB000)                                 = 0
brk(0x006EB000)                                 = 0
brk(0x006ED000)                                 = 0
alarm(300)                                      = 0
read(3, " G E T   / t e s t . h t".., 4096)     = 98
sigaction(SIGUSR1, 0xEFFFD640, 0xEFFFD740)      = 0
time()                                          = 1028149998
alarm(300)                                      = 300
alarm(0)                                        = 300
stat64("/usr/local/src/mod_perl/mod_perl-1.27/t/docs/test.html",
0x006E91E8) = 0
open64("/usr/local/src/mod_perl/mod_perl-1.27/t/.htaccess", O_RDONLY)
Err#2 ENOENT
open64("/usr/local/src/mod_perl/mod_perl-1.27/t/docs/.htaccess", O_RDONLY)
= 5
fstat64(5, 0xEFFFF5C0)                          = 0
fstat64(5, 0xEFFFD420)                          = 0
brk(0x006ED000)                                 = 0
brk(0x006EF000)                                 = 0
ioctl(5, TCGETA, 0xEFFFD3AC)                    Err#25 ENOTTY
read(5, "  ", 8192)                             = 1
read(5, 0x006EB104, 8192)                       = 0
read(5, 0x006EB104, 8192)                       = 0
llseek(5, 0, SEEK_CUR)                          = 1
close(5)                                        = 0
    Incurred fault #6, FLTBOUNDS  %pc = 0x0002D6F0
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000018
    Received signal #11, SIGSEGV [caught]
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000018
sigprocmask(SIG_SETMASK, 0xEF567D90, 0x00000000) = 0
sigaction(SIGSEGV, 0xEFFFF140, 0x00000000)      = 0
sigprocmask(SIG_SETMASK, 0xEF570A90, 0x00000000) = 0
setcontext(0xEFFFF300)
    Incurred fault #6, FLTBOUNDS  %pc = 0x0002D6F0
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000018
    Received signal #11, SIGSEGV [default]
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000018
        *** process killed ***
#

------- truss log end -------

I have used mod_perl up through versions 1.15, using perl 5.004_04,
earlier versions of Apache.  I am trying to upgrade to the latest stable
releases of everything and it just does not seem to be working.  I have
checked the list archives as well as google and anywhere else I could
think of and could not find why it is dying.  Any help is appreciated.

Thank you very much.

JohnM


## John Mendenhall
## jem@electriciti.com
## Senior Network/Systems Administrator

Mime
View raw message