perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Worrall <abworr...@yahoo.com>
Subject Re: Apache::Session problems
Date Thu, 28 Feb 2002 13:00:15 GMT
>>>>> "CW" == Chris Winters <chris@cwinters.com> writes:

    > On Thu, 2002-02-28 at 06:16, Domien Bakker wrote:
    >> 
    >> [Thu Feb 28 11:46:39 2002] [error] Storable binary image v24.48
    >> more recent than I am (v2.4) at blib/lib/Storable.pm (autosplit
    >> into blib/lib/auto/Storable/thaw.al) line 351, at
    >> /usr/local/lib/perl5/site_perl/5.6.1/Apache/Session/Serialize/Storable.p
    >> m line 27

    CW> This sounds like someone with a more recent version of Storable
    CW> in their private lib has been testing sessions or something,
    CW> since there's a mismatch of what is in the database versus the
    CW> module trying to read the data. Be sure you've got the latest
    CW> version of Storable installed.

I had a very similar problem, claiming that the data was serialised
using version 50.xx; I think it indicates that the serialised data is
somehow corrupt. I think I saw it because I had frozen a scalar that was
not a reference, but I could be mistaken.

But it is not a version problem, it just looks like one ;)

Anway, after fixing some other bugs, blowing away the stored items and
re-starting, the problem vanished.

Good luck,

 - Adam

Mime
View raw message