perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Shrewsbury <shr...@lssi.net>
Subject Re: CGI.pm 2.78 and mod_perl 1.26 troubles
Date Thu, 06 Dec 2001 16:45:44 GMT
Solved it... apparently, if you upgrade CGI.pm while your web
server is running, a restart is not good enough. You have to
shutdown completely and then start it back up.

*Sigh*

-David


On Thu, 2001-12-06 at 10:43, David Shrewsbury wrote:
    Hey gang,
    
    I just upgraded the CGI.pm perl module to 2.78 (don't know what the old
    version was) and now none of my scripts running under Apache::Registry
    are working. Instead of executing the scripts, I'm prompted to save the
    script. Here is a sample script:
    
    
       #!/usr/bin/perl
       use CGI qw/:standard/;
    
       print header;
       #print "Content-Type: text/html\n\n";
       print start_html, h1("Hello, World!"), end_html;
    
    
    This works in the regular cgi-bin directory, but not in the directory
    for the mod_perl scripts. Uncomment the line that manually produces the
    header and comment out the call to header() and it works fine.
    
    I'm also getting the occasional error message in the error_log:
    
    	[Thu Dec  6 10:41:53 2001] [error] Can't coerce array into hash 	at
    (eval 35) line 31.
    
    Has anybody else experienced this or have any clue as to what
    may be going on?
    
    
    Here is the perl section of httpd.conf and relevant stats:
    
      Apache 1.3.22
      mod_perl 1.26
      mod_ssl 2.8.5
    
      httpd.conf:
    	Alias /perl/ /usr/local/apachessl/perl/
    	<Location /perl>
    	  SetHandler    perl-script
    	  PerlHandler   Apache::Registry
    	  PerlSendHeader On
    	  Options       +ExecCGI
    	</Location>
    
    	PerlRequire conf/startup.pl
    	PerlFreshRestart On
    	PerlTaintCheck On
    
    -David
    
    


Mime
View raw message