perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan M. Hollin" <netmas...@digital-word.com>
Subject RE: Prototype Mismatch - and AN APOLOGY
Date Wed, 07 Nov 2001 16:55:13 GMT
Perrin,

I'm using PerlRun at the moment because I'm still developing the
application; the production server runs under Registry naturally.

I added the parentheses as you suggested and everything is fine, the
"error.log" is clean - no more problem.  Thank you very much (this has
really been bugging me).


APOLOGY
---------
I posted a message to this list with a small Perl script attached (without
ZIP-ing it first).  This has triggered off numerous bounced mail virus
alerts and I apologise for this.  I will avoid repeating that mistake in
future.  Thank you for your patience.

Jonathan M. Hollin - WYPUG Co-ordinator
West Yorkshire Perl User Group
http://wypug.pm.org/


:: -----Original Message-----
:: From: Perrin Harkins [mailto:perrin@elem.com]
:: Sent: 07 November 2001 16:02
:: To: netmaster@digital-word.com; mod_perl Mailing List
:: Subject: Re: Prototype Mismatch
::
::
:: > In my script a simple "use Image::Magick;" results in the
:: following lines
:: > being added to my error.log everytime the script is called:
::
:: Are you using PerlRun or Registry?
::
:: > Prototype mismatch: sub
:: >
:: Apache::ROOT::shapeshifter::system::pm_files_2ecgi::Transparent vs ($;@)
:: at
:: > E:/Apache/lib/Exporter.pm line 57.
::
:: I'm not sure why this is complaining, but one thing you can do
:: is not import
:: this function.  You can do a 'use Image::Magick ()' and call it
:: with a full
:: package name instead.
::
:: - Perrin
::


Mime
View raw message