perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: Prototype Mismatch
Date Wed, 07 Nov 2001 03:17:39 GMT
Jonathan M. Hollin wrote:

> Platform:
> 
> Microsoft Windows 2000 Server
> Perl 5.6 (Active State)
> mod_perl
> 
> 
> 
> In my script a simple "use Image::Magick;" results in the following lines
> being added to my error.log everytime the script is called:


Jonathan, I think you've sent this to the wrong list. We talk about 
mod_perl here, well mainly. See http://lists.perl.org for the perl lists.

And read 'perldoc perlsub' manpage about prototypes.


> Prototype mismatch: sub
> Apache::ROOT::shapeshifter::system::pm_files_2ecgi::Transparent vs ($;@) at
> E:/Apache/lib/Exporter.pm line 57.
>  at e:/apache/htdocs/shapeshifter/system/image_wizard.pl line 2
> Prototype mismatch: sub
> Apache::ROOT::shapeshifter::system::pm_files_2ecgi::Opaque vs ($;@) at
> E:/Apache/lib/Exporter.pm line 57.
>  at e:/apache/htdocs/shapeshifter/system/image_wizard.pl line 2
> 
> Can anyone explain what I'm doing wrong based on this information?  Is this
> a known bug (as a colleague suggests) and, if so, is there a patch or
> work-around?
> 
> Any help appreciated.
> 
> Thanks in advance.
> 
> Jonathan M. Hollin - WYPUG Co-ordinator
> West Yorkshire Perl User Group
> http://wypug.pm.org/
> 



-- 


_____________________________________________________________________
Stas Bekman             JAm_pH      --   Just Another mod_perl Hacker
http://stason.org/      mod_perl Guide   http://perl.apache.org/guide
mailto:stas@stason.org  http://ticketmaster.com http://apacheweek.com
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/


Mime
View raw message