perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Michael" <jo...@acadiacom.net>
Subject Re: Install problems
Date Sat, 03 Nov 2001 11:28:05 GMT
It looks like in the file apache_request.c these are the lines causing the problem.
#include "httpd.h"

#include "http_config.h"

#include "http_core.h"

#include "http_log.h"

#include "http_main.h"

#include "http_protocol.h"

#include "util_script.h"

John Michael



  ----- Original Message ----- 
  From: John Michael 
  To: modperl@apache.org 
  Sent: Saturday, November 03, 2001 5:21 AM
  Subject: Install problems


  I pieced together this process by looking at a couple of sources to install
  modules.

  I choose the /usr/local/etc directory to start from because I really didn't
  know where this is usually done.
  What directory do you usually start the install from and does it make a
  difference?

  How to install modules:

  cd /usr/local/etc
  upload filename.ver.x.tar.gz file to the /usr/local/etc directory
  gunzip filename.ver.x.tar.gz  the file
  tar xf filename.ver.x.tar  the file
  ch /usr/local/etc/filename.ver.x
  perl Makefile.PL
  make
  make install

  I used it to install Apache::Reload  module and it seemed to work fine.

  I then attemplted to install the libapreq-0.33.tar.gz module and got this
  output when I got to the perl Makefile.PL
  command.

  Checking if your kit is complete.
  Looks good
  Writing Makefile for libapreq
  mkdir blib/lib
  mkdir blib/lib/auto
  mkdir blib/lib/auto/libapreq
  mkdir blib/man3
  cp libapreq.pod blib/lib/libapreq.pod
  cp lib/Apache/libapreq.pm blib/lib/Apache/libapreq.pm
  make[1]: Entering directory `/usr/local/etc/libapreq-0.33/c'
  gcc -c -I/usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/Apache/include -I/us
  r/lib/
  perl5/site_perl/5.6.0/i386-linux/auto/Apache/include/modules/perl -fno-stric
  t-
  aliasing -02 -march=i386 -mcpu=i386 -DVERSION=\"0.10\"  -DXS_VERSION=\"0.10\
  "
   -fPIC -I/usr/lib/perl5/5.6.0/i386-linux/CORE  apache_request.c
  In file included from apache_request.c:58:
  apache_request.h:5:19: httpd.h: No such file or directory
  apache_request.h:6:25: http_config.h: No such file or directory
  apache_request.h:7:23: http_core.h: No such file or directory
  apache_request.h:8:22: http_log.h: No such file or directory
  apache_request.h:9:23: http_main.h: No such file or directory
  apache_request.h:10:27: http_portocol.h: No such file or directory
  apache_request.h:11:25: util_script.h: No such file or directory
  make[1]: *** [apache_request.o] Error 1
  make[1]: Leaving directory `/usr/local/etc/libapreq-0.33/c'
  make[1]: *** [subdirs] Error 2

  I'm confused.

  Thanks
  John Michael


Mime
View raw message