perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wilfredo Sanchez <wsanc...@KnowNow.com>
Subject Re: OT: secure mod_perl enabled apache on MacOSX 10.1
Date Wed, 03 Oct 2001 18:24:24 GMT

On Wednesday, October 3, 2001, at 11:10  AM, Ray Zimmerman wrote:

> I've been able to build a mod_perl enabled apache (not DSO) for Mac OS 
> X 10.1 and it seems to work fine. Now I'd like to include the 
> apple_hfs_module or hfs_apple_module that Apple included as a DSO in 
> the standard install to take care of some security issues related to 
> the case-insensitivity of the HFS+ file system.

   /usr/libexec/httpd/libperl.so ships with 10.1; there's usually no need 
to build your own.  Just uncomment the LoadModule/AddModule lines 
referencing perl in /etc/httpd/httpd.conf.

   For what it's worth, I've heard that mod_hfs_apple is broken in 10.1, 
but I haven't verified that.

	-Fred


Mime
View raw message