perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Issac Goldstand" <mar...@beamartyr.net>
Subject Re: DB_File needs compatible versions
Date Wed, 03 Oct 2001 09:06:06 GMT
I originally just posted this back to Scott, but after seeing all the flurry of activity regarding
this lately, here's my $0.02 on the issue...

-----Original Message-----
I've had this problem.  The problem is actually in the RPM for perl, which
in it's default make notices this problem and removes db.h from perl.  I've
discovered, however, that you can build perl yourself and simply put db.h
back into perl at the end of the ./configure script (right before making
dependancies by editing the config.sh file and adding -ldb to LIBS).

After building the (addmittadly possibly mismatched) libdb, perl lets you rebuild it over
and over if you so wish, and I've yet to run into problems...

  Issac

Internet is a wonderful mechanism for making a fool of
yourself in front of a very large audience.
  --Anonymous

Moving the mouse won't get you into trouble...  Clicking it might.
  --Anonymous

PGP Key 0xE0FA561B - Fingerprint:
7E18 C018 D623 A57B 7F37 D902 8C84 7675 E0FA 561B





Mime
View raw message