perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brendan McAdams" <b.mcad...@themunicenter.com>
Subject RE: mod_perl help
Date Tue, 24 Apr 2001 16:20:43 GMT
I'm not sure if mod_perl will work with activeperl

-----Original Message-----
From: abhishek agrawal [mailto:abhishek.agrawal@lycos.com]
Sent: Tuesday, April 24, 2001 11:50
To: modperl@apache.org
Subject: mod_perl help


Hi,
 
      I have been trying to run perl scripts on apache using mod_perl. I
initially had perl5.6.0 which came with the Redhat. I then configured my
apache and got simple per scripts running. Then i realised that most of
the perl scripts which will eventually run on my machine are wirtten in
Activeperl, i installed activeperl ( for linux).

but then when i tried running perl scripts which used modules such as
Date::Calc, i get errors such as 
"Cant find loadabel object module "

I am sure that i have installed the modules correctly using the ppm. 

Someone suggested me that the mod_perl is built using different perl
(perl5) and the perl which is running on my machine is different (Active
perl). Hence it is causing problem. So i removed the perl5 completely
from my machine and tried building mod_perl again. But when i tried
bulding mod_perl again, i gave me and error saying that "it need
perl5.6.0"

Does Active perl does not work properly with mod_perl? If yes, can you
tell me where exactly am i making mistake.

I have been stuck with this problem for more than 2 weeks now, and any
help will be greatly appreciated.

yours truely,
Abhishek
       

_____________________________________
The reward for working hard is more hard work.




MESG «(`P_BE
On Tue, 24 Apr 2001 13:34:49  
 Stas Bekman wrote:
>> At least two people responded to my last message telling me that they
>> didn't like Slash much; it was a horrible piece of code.  Are you
>> refering to it as a general piece of Perl code, or how it deals with
>> mod_perl?  If the latter, where I can find some good code to look it?
>
>Once you do something not very cleanly people will remember for a long
>time. I didn't check the latest versions of it, I suppose it's much
much
>better now. It's rewritten by different people too.
>
>> Also, Apache can't recognize the <Perl> directive; it gives me the
>> following error:
>>
>> Invalid command '<Perl>', perhaps mis-spelled or defined by a module
not
>> included in the server configuration
>
>Please read the documentation before posting. e.g. see:
>http://perl.apache.org/guide/config.html#Enabling
>
>> mod_perl.c seems to be installed.  'httpd -l' shows it listed at the
>> bottom.  I've added the directive 'AddModule mod_perl.c' to
httpd.conf,
>> and it doesn't throw an error, so I know /something/ is being loaded,
>> but the <Perl> directive still doesn't work.
>>
>> Am I missing something?
>
>see above
>
>_____________________________________________________________________
>Stas Bekman              JAm_pH     --   Just Another mod_perl Hacker
>http://stason.org/       mod_perl Guide  http://perl.apache.org/guide
>mailto:stas@stason.org   http://apachetoday.com http://eXtropia.com/
>http://singlesheaven.com http://perl.apache.org http://perlmonth.com/
>
>
>


Get 250 color business cards for FREE!
http://businesscards.lycos.com/vp/fastpath/

Mime
View raw message