perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Heiss" <Christ...@heiss-net.de>
Subject Apache::AuthDBI
Date Sun, 22 Apr 2001 14:31:17 GMT
Hi,

I'm using Apache::AuthDBI to verifying the users on my web site.



I can connect to the the protected site, but there is a output in the error log:

----------------------------------------------------------------------------------------------------------------------------------------
>Use of uninitialized value at /usr/lib/perl5/site_perl/5.005/Apache/AuthDBI.pm line 450
>Use of uninitialized value at /usr/lib/perl5/site_perl/5.005/Apache/AuthDBI.pm line 480
>Use of uninitialized value at /usr/lib/perl5/site_perl/5.005/Apache/AuthDBI.pm line 481
----------------------------------------------------------------------------------------------------------------------------------------

To crypt the the passwords I'm using something like this:
----------------------------------------------------------------------------------------------------------------------------------------
>my $userid = $query->param('userid');
> my $pass = $query->param('pass');
> my $groupid = $query->param('groupid');
>my $fullname = $query->param('fullname');
 
 $pass = crypt("$pass", "$userid");
----------------------------------------------------------------------------------------------------------------------------------------

then I put it in the database with:
----------------------------------------------------------------------------------------------------------------------------------------
>my $sql = "INSERT INTO <table name> VALUES($userid, $groupid, $pass, ...);
of course, before I'm using the quote funktion ($dbh->quote($userid)...)...
----------------------------------------------------------------------------------------------------------------------------------------

and my .htacces is:
----------------------------------------------------------------------------------------------------------------------------------------
>PerlModule Apache::AuthDBI
>AuthName "something else"
>AuthType Basic
>PerlAuthenHandler Apache::AuthDBI::authen
>PerlAuthzHandler Apache::AuthDBI::authz
>PerlSetVar Auth_DBI_encrypted on
>PerlSetVar Auth_DBI_data_source dbi:mysql:<database>
>PerlSetVar Auth_DBI_username <user name>
>PerlSetVar Auth_DBI_password <password>
>PerlSetVar Auth_DBI_pwd_table <table name>
>PerlSetVar Auth_DBI_uid_field <userid field>
>PerlSetVar Auth_DBI_grp_field <groupid field>
>PerlSetVar Auth_DBI_pwd_field <password field>

>require valid-user

>allow from all
----------------------------------------------------------------------------------------------------------------------------------------



Anybody knows how to stop this error output?

Thanks a lot

Christian HeiƟ

Mime
View raw message