perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vasily Petrushin <tai...@interfax.ru>
Subject Re: Error reporting mod_perl 1.25 + apache 1.3.17
Date Wed, 07 Feb 2001 10:54:09 GMT

I removed this problem on Solaris 8 SPARC by compiling perl 5.6.0
with -Ubincompat and -Uuselargefiles and compiling mod_perl 1.25 + apache
1.3.17 statically.
Now httpd process eating less memory :).
It's cool.

On Tue, 6 Feb 2001, dima wrote:

> 
> I used to have all these seg faults when dealing with apache1.3.14 and
> mod_perl1.24_01 (perl5.6.0/redhat 6.2) when built as DSO. As soon as you
> get a request through log files just get flooded with segmentation faults.
>  However when I switched over to apache1.3.17 + mod_perl1.25 everything
> goes on just fine.
>  Try using PERL_USELARGEFILES=0 when building mod_perl too.
> 
> cheers,
> dima
> 
> On Mon, 5 Feb 2001, modperl wrote:
> 
> > Actually My current builds are very similar. 1.3.17+1.25w/5.6.0 on
> > slackware linux 7.1, dually intel boxes.
> > Works fine and while watching error logs i haven't seen any
> > segfaults. returns our pages just fine.
> >
> > Scott
> >
> > On Mon, 5 Feb 2001, Paul Lindner wrote:
> > > On Mon, Feb 05, 2001 at 06:41:00PM +0000, G.W. Haywood wrote:
> > > > Hi there,
> > > > On Mon, 5 Feb 2001, Matisse Enzer wrote:
> > > > > I compiled perl 5.6 and Apache 1.3.17 using gcc egcs-2.91.66
> > > > > on a RH Linux 6.1 system.
> > > > I'm sure there must be people on this List who have successfully built
> > > > mod_perl systems using exactly the packages you have mentioned.
> > > > Anyone care to confirm that?
> > > I've seen some strange segementation fault problems with mod_perl
> > > 1.25.  I have not had the time to document these.
> > > Environment is similar to others: mod_perl 1.25, apache 1.3.17, perl
> > > 5.00503, solaris 2.6...
> >
> >
> 
> 

Vasily Petrushin
+7 (095) 2508363
http://www.interfax.ru
mailto:tainos@interfax.ru


Mime
View raw message