perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brad Howerter <bho...@woodward.com>
Subject RE: Apache::DBI::connect problem, please help
Date Wed, 21 Feb 2001 15:09:23 GMT
Thank you, Geoff and Arun.  I am doing it the way you suggest.

My problem turned out to be a bad installation of Apache::DBI.pm.
(it was just a copy of DBI.pm).

> -----Original Message-----
> From: Arun Theeban [mailto:atheeban@yahoo.com]
> Sent: Tuesday, February 20, 2001 11:39 PM
> To: Geoffrey Young; 'Brad Howerter'; 'modperl@apache.org'
> Subject: RE: Apache::DBI::connect problem, please help
> 
> 
> You have to put Apache::DBI before any of the DBI's
> you are using in httpd.conf file.
> 
> In your cgi programs use only "DBI" not "Apache::DBI"
> module.
> 
> a simple program would be.
> 
> #! /usr/bin/perl
> print "Content-type:text/html\n\n";
> $dbh=DBI->connect("DBI::Pg::dbname=emp","user","passwod");
> print "<body> connected successfully </body>";
> $dbh->disconnect;
> 
> if Apache::DBI was loaded before DBI, some of the
> fuctions would be overridden.
> 
> Even if you give $dbh->disconnect,Apache::DBI will
> override funtion to nothing.
> -Arun
> 
> --- Geoffrey Young <gyoung@laserlink.net> wrote:
> > 
> > 
> > > -----Original Message-----
> > > From: Brad Howerter [mailto:bhower@woodward.com]
> > > Sent: Tuesday, February 20, 2001 12:57 PM
> > > To: 'modperl@apache.org'
> > > Subject: RE: Apache::DBI::connect problem, please
> > help
> > > 
> > [snip]
> > > So Apache/DBI.pm must be installed incorrectly on
> > my system.
> > > It's supposed to be different from the DBI.pm?
> > 
> > yup, you need both.  DBI is, well, DBI.  Apache::DBI
> > is a persistent
> > framework under mod_perl that uses DBI.
> > 
> > HTH
> > 
> > --Geoff 
> k
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Auctions - Buy the things you want at great prices! 
http://auctions.yahoo.com/

Mime
View raw message