perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wang, Pin-Chieh" <Pin-Chieh.W...@COMPAQ.com>
Subject RE: Apache::ASP
Date Thu, 01 Feb 2001 21:27:45 GMT

>If Ged did not answer your question well enough, check out
>this answered as an FAQ item at:

>
http://www.apache-asp.org/faq.html#Apache%20errors%20on%20the%20PerlHandler%
20directive%20%3F

>--Josh

Hi, Josh,
I now re-installed a fresh copy Apache_1.3.14 with mod_perl-1.24_01 with
USE_DSO=1
  -- now the LoadModule and AddModule directive is automatically added in
httpd.conf 
I then did the following steps
1. Installed Apache-ASP-2.07
2. Copied Apache-ASP-2.07/site/eg directory into /usr/local/apache/htdocs
3. Modified httpd.conf file by adding 
    <Directory "/usr/local/apache/ htdocs/eg">
	Options All
	AllowOverride All
	Order allow,deny
	Allow from all
     </Directory>
   AND
     <Location /asp/>
	SetHandler perl-script
	PerlHandler Apache:ASP
	PerlSetVar Global /tmp
     </Location>

When I call http://host/eg/index.html to test asp I got
	#!/usr/local/bin/perl5 asp
	[0]%>>    ([0]%>>source)

on the browser

there is no error at error_log. and the perl on my machine is at
/usr/local/perl and is 5.6
I tried to modify the #! line to indicate the location of local perl, but
still not work.

any body give me any guidance?

Thanks

PC




Mime
View raw message