perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Eberle <bill.ebe...@zinza.com>
Subject Location directive not working for mod perl
Date Tue, 26 Dec 2000 13:48:03 GMT
I hope this is the correct mailing list for newbie mod perl questions.
I have just installed mod_perl 1.24 with Apache 1.3.14.  Mod perl seems
to be running because upon startup of httpd, the Apache error log file
says

Apache/1.3.14 (Unix) mod_perl/1.24_02-dev configured -- resuming normal
operations

The problem I'm having is that the Location directive does not seem to
be working.  I have the following in my httpd.conf file:

Alias  /perl/  "/home/httpd/perl"

<Location /perl>
     SetHandler perl-script
     PerlHandler Apache::Registry
     Options +ExecCGI
     allow from all
     PerlSendHeader On
</Location>

I have placed a file called test-cgi in the directory
"/home/httpd/perl/".  It is executable and runs if executed from the
command line.  However, when I try to call this script through the
browser using the URL http://localhost/perl/test-cgi I get a 404 not
found error (The requested URL /perl/test-cgi was not found on this
server.The requested URL /perl/test-cgi was not found on this server.)

The ScriptAlias directive works fine.  I have:

ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"

and the same file (test-cgi) placed in /usr/local/apache/cgi-bin
executes without problems.

This all seems very simple so I don't understand what I'm doing wrong.
Any ideas anyone?



Mime
View raw message