perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gunther Birznieks <gunt...@extropia.com>
Subject Re: bogus taint error?
Date Mon, 03 Jul 2000 04:43:30 GMT
Did you do a hard shutdown and start of your web server or just a normal 
restart. If you did the normal restart, try doing the shutdown and start 
operations separately

At 09:31 PM 7/2/00 -0700, Michael Blakeley wrote:
>At 3:37 PM -0700 7/2/2000, Michael Blakeley wrote:
>>At 2:00 PM -0700 7/2/2000, Michael Blakeley wrote:
>>>With perl 5.6.0, Solaris 2.6, apache 1.3.9, and mod_perl 1.24, I'm 
>>>seeing intermittent taint errors like
>>>[Sat Jul  1 18:50:13 2000] [error] PerlRun: `Insecure dependency in 
>>>require while running with -T switch at /foo.pl line 5.
>
>This is just plain weird. My last resort was to turn taint off:
>
>$ ls -l logs/httpd.pid
>-rw-rw-rw-   1 root     other          6 Jul  2 19:23 logs/httpd.pid
>$ grep -i taint conf/httpd.conf
>#PerlTaintCheck On
>$ ls -l conf/httpd.conf
>-rw-r--r--   1 root     other       7437 Jul  2 17:22 conf/httpd.conf
>
>I'm not including any sort of startup.pl file. So taint is off, right?
>
>error log:
>[Sun Jul  2 21:20:20 2000] [error] Insecure dependency in require while 
>running with -T switch at (eval 756) line 3.
>
>This system used to be stable, and I can't find anything that's changed. 
>Sunspots?
>
>Thanks for any ideas.
>
>-- Mike

__________________________________________________
Gunther Birznieks (gunther.birznieks@extropia.com)
eXtropia - The Web Technology Company
http://www.extropia.com/


Mime
View raw message