perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Almetaal B.V." <webmas...@almetaal.com>
Subject Apache::ASP - problem with installing Apache::SSI & ::Filter
Date Wed, 05 Jul 2000 10:22:42 GMT
I'm trying to install Apache::SSI & Apache::Filter via CPAN, but it fails
[see errors below]. I can remember this problem from another server, but I
forgot the solution....

My Apache (1.3.12) has been compiled with mod_ssl/2.6.4 (OpenSSL/0.9.5a),
PHP/4.0.1pl2, mod_perl/1.24. I have all modules as DSO's, except for
mod_perl (a 'static module', eg. there is no AddModule for mod_perl in
httpd.conf, just a LoadModule). [http://maddog2k.2fast.nl/info.php]

Do you have any clue on how to solve this ?

Thanks in advance,

--
Wouter de Jong
Developer
Advanced IT Services Holland
http://www.aitsh.com
wouter@aitsh.nl

==========
Error-msgs :
==========

For testing purposes, please give the full path to an httpd with mod_perl.
The path defaults to $ENV{APACHE}, if present.

 [/usr/lib/httpd/httpd]: /usr/local/apache/bin/httpd
User to run tests under [root]: nobody
Group to run tests under [nobody]: nobody
Port to run tests under [8228]:
Checking if your kit is complete...
Looks good
Writing Makefile for Apache::SSI
mkdir blib
mkdir blib/lib
mkdir blib/lib/Apache
mkdir blib/arch
mkdir blib/arch/auto
mkdir blib/arch/auto/Apache
mkdir blib/arch/auto/Apache/SSI
mkdir blib/lib/auto
mkdir blib/lib/auto/Apache
mkdir blib/lib/auto/Apache/SSI
mkdir blib/man3
cp SSI.pm blib/lib/Apache/SSI.pm
Manifying blib/man3/Apache::SSI.3
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1
/usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.00503/i386-linux -I/
usr/lib/perl5/5.00503 -e 'use Test::Harness qw(&runtests $verbose);
$verbose=0; runtests @ARGV;' t/*.t
t/fake..............ok
t/real..............Starting http server... Syntax error on line 15 of
/root/.cpan/build/Apache-SSI-2.13/t/httpd.conf:
Invalid command 'TypesConfig', perhaps mis-spelled or defined by a module
not included in the server configuration
Can't start httpd: Illegal seek at real.t line 100, <LOC> chunk 4.
dubious
        Test returned status 29 (wstat 7424, 0x1d00)
Undefined subroutine &Test::Harness::WCOREDUMP called at
/usr/lib/perl5/5.00503/Test/Harness.pm line 288.
make: *** [test_dynamic] Error 29
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force

----------------------------------------------------------------------------
---------------------------------------------

For testing purposes, please give the full path to an httpd
with mod_perl enabled.  The path defaults to $ENV{APACHE}, if present.

 [/usr/lib/httpd/httpd]: /usr/local/apache/bin/httpd
User to run tests under [nobody]:
Group to run tests under [nobody]:
Port to run tests under [8228]:
Checking if your kit is complete...
Looks good
Writing Makefile for Apache::Filter
mkdir blib
mkdir blib/lib
mkdir blib/lib/Apache
mkdir blib/arch
mkdir blib/arch/auto
mkdir blib/arch/auto/Apache
mkdir blib/arch/auto/Apache/Filter
mkdir blib/lib/auto
mkdir blib/lib/auto/Apache
mkdir blib/lib/auto/Apache/Filter
mkdir blib/man3
cp Filter.pm blib/lib/Apache/Filter.pm
cp lib/Apache/RegistryFilter.pm blib/lib/Apache/RegistryFilter.pm
Manifying blib/man3/Apache::RegistryFilter.3
/usr/bin/pod2man: Unrecognized pod directive in paragraph 25 of
lib/Apache/RegistryFilter.pm: =back
Manifying blib/man3/Apache::Filter.3
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1
/usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.00503/i386-linux -I/
usr/lib/perl5/5.00503 -e 'use Test::Harness qw(&runtests $verbose);
$verbose=0; runtests @ARGV;' t/*.t
t/filehandle........ok
t/real..............Starting http server... Syntax error on line 27 of
/root/.cpan/build/Apache-Filter-1.011/t/httpd.conf:
Invalid command 'TypesConfig', perhaps mis-spelled or defined by a module
not included in the server configuration
Can't start httpd: Illegal seek at real.t line 96, <LOC> chunk 4.
dubious
        Test returned status 29 (wstat 7424, 0x1d00)
Undefined subroutine &Test::Harness::WCOREDUMP called at
/usr/lib/perl5/5.00503/Test/Harness.pm line 288.
make: *** [test_dynamic] Error 29
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force


Mime
View raw message