perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug MacEachern <do...@covalent.net>
Subject Re: Apache::PerlVINC again
Date Thu, 01 Jun 2000 19:52:05 GMT
On Thu, 1 Jun 2000, Kees Vonk 7249 24549 wrote:

> The following works on Apache/1.3.6 (Unix) mod_perl/1.21 
> mod_ssl/2.3.5 OpenSSL/0.9.3a
> 
> But when running on Apache/1.3.9 (Unix) mod_perl/1.21 
> mod_ssl/2.4.8 OpenSSL/0.9.4, I get the following problem 
> which _appears_ (I am not 100% sure) to be caused by 
> Apache::PerlVINC. I have the following section in my 
> httpd.conf
... 
> The moment I uncomment the PerlVINC lines (or even just the first one) 
> apache fails to start without any error message (STDOUT or logs (LogLevel 
> debug)) or core file.

you'll need to try this:

Date: Thu, 25 May 2000 12:13:20 -0700 (PDT)
From: Doug MacEachern <dougm@covalent.net>
To: Roberto Bourgonjen <roberto@Toutatis.COM>
cc: modperl@apache.org
Subject: Re: httpd exits with apache-1.3.12 and mod_perl-1.21 on Redhat
6.2

On Wed, 24 May 2000, Roberto Bourgonjen wrote:

> Hi all,
> 
> I am encountering strange problems on redhat 6.2 installations with
> rpm's apache-1.3.12-2 and mod_perl-1.21-10 (the latest available
> versions from redhat. I _have_ to use rpm's). I've tried two machines.
> 
> As soon as load certain modules the server exits immediately, without 
> producing the slightest error message.

try this:

% gdb httpd
(gdb) b exit
(gdb) run -X

whether it core dumps or exit() is called, post the output of:

(gdb) bt




Mime
View raw message