perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tim fulcher <fulch...@drink.bt.co.uk>
Subject problem with IO::Select under Apache::Registry (long)
Date Thu, 01 Jun 2000 16:08:48 GMT

Hi,

I'm starting to play around with mod_perl, beginning with moving some
stuff under Apache Registry from cgi-bin.

One script makes use of the Msg.pm module I nicked from the O'Reilly
Advanced Perl Programming Book, to send a message from the web server to
another machine. This all worked fine under cgi-bin, but under the
Registry, the script fails to compile.

In the error_log is the message

[Thu Jun  1 13:51:55 2000] [error] [Thu Jun  1 13:51:55 2000]
getSNum.pl: [Thu Jun  1 13:51:55 2000] Msg.pm: [Thu Jun  1 13:51:55
2000] Msg.pm: Can't call method "new" without a package or object
reference at /usr/borg/lib/perl5/5.00503/Msg.pm line 11.
[Thu Jun  1 13:51:55 2000] getSNum.pl: BEGIN failed--compilation aborted
at /export/tools/apache/perl/getSNum.pl line 8.

The offending line in Msg.pm is

$rd_handles   = IO::Select->new();

So being a good netizen I checked this list's archive's before posting
this, and found a similar query by Barry Hoggard Dec 99 re: IO::Select
usage in LWP. He fixed his problem by putting "" quotes round
IO::Select, but I tried that for me with no success.

Any ideas ???

environment:

Solaris 2.6
apache 1.3.9
mod_perl 1.21
perl 5.00503

cheers

Tim Fulcher


Mime
View raw message