perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug MacEachern <do...@pobox.com>
Subject Re: Errors while installing Apache::Request
Date Tue, 07 Mar 2000 02:26:35 GMT
On Tue, 7 Mar 2000, Jens-Uwe Mager wrote:
 
> There is one other loose end that I would like to take care about, namely
> my small patch needed to the base perl 5.005_3 for AIX distribution that
> fixes a problem that symbols are not properly resolved if mod_perl is a
> DSO itself (the original loader assumed it is always in the main
> executable). Would it be possible to put that into the INSTALL document
> anywhere? I will need to get that into later perl releases as well, but
> it will hit mostly folks installing mod_perl so a hint in the INSTALL
> file would be fine.

i'd be happy to have a note in the INSTALL file, maybe even include the
patch (or url to it), along with adding to system_sanity_check() in
Makefile.PL that does something like:

if ($^O eq 'aix' and $USE_DSO) {
     phat_warn("...you should apply this patch...");
}


Mime
View raw message