perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug MacEachern <do...@pobox.com>
Subject Re: Errors while installing Apache::Request
Date Wed, 01 Mar 2000 06:47:11 GMT
On Thu, 17 Feb 2000, J. Meltzer wrote:

> While installing either Apache::Request or the full libapreq package, I get 
> to the "make test" step, and the following errors pop up.  (Apache 
> 1.3.11,mod_perl 1.21, AIX 4.3.3)
> 
> Note:  All other installations so far have worked fine.  These errors occur 
> whether I install by hand, or install using the CPAN module.  Any help is 
> welcomed.  I received some help from Geoffrey Young already, for which I am 
> grateful, because I did not want to bother the list again after my last 
> time.  However, we were not able to figure this out.

I don't expect libapreq (or any of the Apache:: xs modules outside of
the mod_perl dist)  to work under aix. it needs to point at the apache and
mod_perl .exp files to link properly.  I don't have access to an aix box
at the moment, maybe one of our aix experts can help here?  a patch to
Apache::src would be ideal so all the Apache:: xs modules on cpan can use
it.  the Apache:: xs modules that ship with mod_perl don't have this
problem because they are all linked static by default.


Mime
View raw message