perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens-Uwe Mager <...@helios.de>
Subject Re: Errors while installing Apache::Request
Date Thu, 02 Mar 2000 18:46:51 GMT
On Tue, Feb 29, 2000 at 10:47:11PM -0800, Doug MacEachern wrote:

> I don't expect libapreq (or any of the Apache:: xs modules outside of
> the mod_perl dist)  to work under aix. it needs to point at the apache and
> mod_perl .exp files to link properly.  I don't have access to an aix box
> at the moment, maybe one of our aix experts can help here?  a patch to
> Apache::src would be ideal so all the Apache:: xs modules on cpan can use
> it.  the Apache:: xs modules that ship with mod_perl don't have this
> problem because they are all linked static by default.

That is a sticky problem, and I only got it to work by patching the
generated Makefiles by hand. As I see it, Apache::src would not help
here, the mod_perl install procedure needs to install the mod_perl.exp
file at the same location as the httpd.exp file is found, namely in the
Apache directory libexec. I did already submit a patch to mod_perl in
last August (that was not applied for some reason), that does reference
the httpd.exp file at its standard location. What about installing the
mod_perl.exp there and simply reference that from the libapreq Makefile
if AIX is the platform?

-- 
Jens-Uwe Mager

HELIOS Software GmbH
Steinriede 3
30827 Garbsen
Germany

Phone:		+49 5131 709320
FAX:		+49 5131 709325
Internet:	jum@helios.de

Mime
View raw message