perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Sparks" <aspa...@cpd.harris.com>
Subject Re: Why 'require' required?
Date Sat, 25 Mar 2000 00:24:38 GMT
Because Apache "knows" that without "require" lines, no user authentication
calls are needed.  Not mod_perl, but a core Apache algorithm.
-Alan

-----Original Message-----
From: Jie Gao <J.Gao@isu.usyd.edu.au>
>
>I have this in my .htaccess file:
>

[config snipped]
>Now if I comment out "require valid-user", neither of the
>PerlAuthenHandler and PerlAuthzHandler will be evoked, even though it
>is a phoney requirement for my handler; if I put in one require
>statement, like 'require authentication', it'll start working again.



Mime
View raw message