perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Singh" <psi...@mallnetmedia.com>
Subject Can't coerce GLOB to string
Date Tue, 15 Feb 2000 19:18:30 GMT
Hello all,

I'm getting a strange error that I can't figure out... my script works fine
until the Apache::exit() call, at which point I sometimes get the following
error in the error_log:

    [Mon Feb 14 16:16:30 2000] [error] Can't coerce GLOB to string in
entersub at /home/httpd/perl/points/points.pl line 97.

The strange thing is that I am not using globs anywhere (at least not
intentionally) and the problem only appears occasionally (in particular,
right after restarting the server).  I am not using any global variables.
The problem does not appear when I run the exact same script as a normal
CGI, but the problem does happen when I run Apache in single server mode
(i.e., httpd -X).

Please help as I'm aging prematurely trying to figure this thing out... any
guidance would be appreciated...
_____

Paul Singh
psingh@mallnetmedia.com
phone 212.949.1728 / fax 212.949.1729


Mime
View raw message