perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From steve...@apache.org
Subject svn commit: r1678564 - in /perl/modperl/trunk/t/api: access2.t access2_24.t
Date Sun, 10 May 2015 14:56:20 GMT
Author: stevehay
Date: Sun May 10 14:56:20 2015
New Revision: 1678564

URL: http://svn.apache.org/r1678564
Log:
t/api/access2.t and t/api/access2_24.t need mod_version.c (not just 'version' otherwise that
picks up perl's version.pm!) because t/response/TestAPI/access2.pm and t/response/TestAPI/access2_24.pm
write out httpd.conf snippets with IfVersion directives.

The omission of this requirement was causing t/api/access2.t to fail on Win32 with httpd-2.2.29,
in which the default httpd.conf (which Apache::TestConfigParse::inherit_config() uses to set
up LoadModule directives in our t/conf/httpd.conf) has "LoadModule version_module modules/mod_version.so"
(and many others) commented-out (despite all modules having been made).

Modified:
    perl/modperl/trunk/t/api/access2.t
    perl/modperl/trunk/t/api/access2_24.t

Modified: perl/modperl/trunk/t/api/access2.t
URL: http://svn.apache.org/viewvc/perl/modperl/trunk/t/api/access2.t?rev=1678564&r1=1678563&r2=1678564&view=diff
==============================================================================
--- perl/modperl/trunk/t/api/access2.t (original)
+++ perl/modperl/trunk/t/api/access2.t Sun May 10 14:56:20 2015
@@ -8,7 +8,8 @@ use Apache::TestRequest;
 
 if (!have_min_apache_version("2.4.0")) {
 
-plan tests => 6, need need_lwp, need_auth, need_access, 'HTML::HeadParser';
+plan tests => 6, need need_lwp, need_auth, need_access, 'mod_version.c',
+    'HTML::HeadParser';
 
 my $location = "/TestAPI__access2";
 

Modified: perl/modperl/trunk/t/api/access2_24.t
URL: http://svn.apache.org/viewvc/perl/modperl/trunk/t/api/access2_24.t?rev=1678564&r1=1678563&r2=1678564&view=diff
==============================================================================
--- perl/modperl/trunk/t/api/access2_24.t (original)
+++ perl/modperl/trunk/t/api/access2_24.t Sun May 10 14:56:20 2015
@@ -7,7 +7,8 @@ use Apache::TestRequest;
 
 if (have_min_apache_version("2.4.0")) {
 
-plan tests => 6, need need_lwp, need_auth, need_access, 'HTML::HeadParser';
+plan tests => 6, need need_lwp, need_auth, need_access, 'mod_version.c',
+    'HTML::HeadParser';
 
 my $location = "/TestAPI__access2";
 



Mime
View raw message