perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From steve...@apache.org
Subject svn commit: r1502135 - in /perl/modperl/branches/httpd24/src/modules/perl: modperl_apache_compat.c modperl_apache_compat.h
Date Thu, 11 Jul 2013 07:23:32 GMT
Author: stevehay
Date: Thu Jul 11 07:23:31 2013
New Revision: 1502135

URL: http://svn.apache.org/r1502135
Log:
Don't use AP_DECLARE when declaring/defining our own versions of functions no longer in httpd

The AP_DECLARE macro marks symbols as "dllexport" when compiled in httpd or as "dllimport"
when compiled in third-party code such as mod_perl, but defining a function marked "dllimport"
isn't allowed.

Modified:
    perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.c
    perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.h

Modified: perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.c
URL: http://svn.apache.org/viewvc/perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.c?rev=1502135&r1=1502134&r2=1502135&view=diff
==============================================================================
--- perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.c (original)
+++ perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.c Thu Jul 11 07:23:31
2013
@@ -62,7 +62,7 @@ AP_DECLARE(const char *) ap_get_server_b
                   MP_FUNC, ver, fallback); \
     }
 
-AP_DECLARE(const char *) ap_get_server_version(void) {
+const char * ap_get_server_version(void) {
     modperl_warn_deprecated_http_function("2.3.0",
         "ap_get_server_(description|banner)");
     return ap_get_server_banner();

Modified: perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.h
URL: http://svn.apache.org/viewvc/perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.h?rev=1502135&r1=1502134&r2=1502135&view=diff
==============================================================================
--- perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.h (original)
+++ perl/modperl/branches/httpd24/src/modules/perl/modperl_apache_compat.h Thu Jul 11 07:23:31
2013
@@ -50,7 +50,7 @@ AP_DECLARE(const char *) ap_get_server_b
 #if AP_MODULE_MAGIC_AT_LEAST(20060905,0)
 
 /* removed in APACHE-2.3.0 */
-AP_DECLARE(const char *) ap_get_server_version(void);
+const char * ap_get_server_version(void);
 
 #endif /* since-APACHE-2.3.0 */
 



Mime
View raw message