perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject svn commit: r164866 - in /perl/modperl/trunk: Changes Makefile.PL
Date Tue, 26 Apr 2005 19:36:37 GMT
Author: stas
Date: Tue Apr 26 12:36:36 2005
New Revision: 164866

URL: http://svn.apache.org/viewcvs?rev=164866&view=rev
Log:
improve the diagnostics when detecting mp2 < 1.999022, tell the user
which files and/or dirs need to be removed

Modified:
    perl/modperl/trunk/Changes
    perl/modperl/trunk/Makefile.PL

Modified: perl/modperl/trunk/Changes
URL: http://svn.apache.org/viewcvs/perl/modperl/trunk/Changes?rev=164866&r1=164865&r2=164866&view=diff
==============================================================================
--- perl/modperl/trunk/Changes (original)
+++ perl/modperl/trunk/Changes Tue Apr 26 12:36:36 2005
@@ -12,6 +12,9 @@
 
 =item 1.999_23-dev
 
+improve the diagnostics when detecting mp2 < 1.999022, tell the user
+which files and/or dirs need to be removed [Stas]
+
 restore the DESTDIR support partially nuked by the apache2 rename
 branch [Torsten Förtsch <torsten.foertsch gmx.net>]
 

Modified: perl/modperl/trunk/Makefile.PL
URL: http://svn.apache.org/viewcvs/perl/modperl/trunk/Makefile.PL?rev=164866&r1=164865&r2=164866&view=diff
==============================================================================
--- perl/modperl/trunk/Makefile.PL (original)
+++ perl/modperl/trunk/Makefile.PL Tue Apr 26 12:36:36 2005
@@ -9,7 +9,7 @@
 use constant MIN_HTTPD_VERSION_DYNAMIC => '2.0.47';
 use constant MIN_HTTPD_VERSION_STATIC  => '2.0.51';
 
-my($old_modperl_version, $old_modperl_pm);
+my($old_modperl_version, $old_modperl_pm, $old_Apache2_pm);
 
 BEGIN {
     eval {
@@ -18,6 +18,7 @@
         if ($mod_perl::VERSION < 1.999_22 && $old_mp2) {
             $old_modperl_version = $mod_perl::VERSION;
             $old_modperl_pm = delete $INC{'mod_perl.pm'};
+            $old_Apache2_pm = delete $INC{'Apache2.pm'};
         }
     };
 }
@@ -142,10 +143,25 @@
                 "no collision)\n";
         }
         else {
+            my @files = ();
+            my @dirs = ();
+            push @files, $old_Apache2_pm if $old_Apache2_pm;
+            push @dirs, $path
+                if $path =~ /Apache2/ or $old_modperl_version > 1.99;
+
+            my $note = '';
+            if (@files || @dirs) {
+                $note  = "Problematic\n";
+                $note .= "files: @files\n" if @files;
+                $note .= "dirs: @dirs\n"   if @dirs;
+            }
+
             print " not ok\n\n";
             print <<EOI;
 Cannot install mod_perl/$VERSION on top of $vstring
 due to a major API change between mod_perl 1.999_21 and 1.999_22.
+
+$note
 Please nuke the prior mod_perl installation from your site_lib,
 use a different perl to run the installation process, or use the
 PREFIX option when creating your Makefile.  see



Mime
View raw message