perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject cvs commit: modperl-2.0 Changes Makefile.PL
Date Mon, 06 Sep 2004 15:52:28 GMT
stas        2004/09/06 08:52:28

  Modified:    .        Changes Makefile.PL
  Log:
  Fix the error message when the minimal required httpd version is not
  satisfied
  Submitted by:	Pratik <pratiknaik@gmail.com>
  
  Revision  Changes    Path
  1.472     +3 -0      modperl-2.0/Changes
  
  Index: Changes
  ===================================================================
  RCS file: /home/cvs/modperl-2.0/Changes,v
  retrieving revision 1.471
  retrieving revision 1.472
  diff -u -u -r1.471 -r1.472
  --- Changes	27 Aug 2004 01:34:29 -0000	1.471
  +++ Changes	6 Sep 2004 15:52:28 -0000	1.472
  @@ -12,6 +12,9 @@
   
   =item 1.99_17-dev
   
  +Fix the error message when the minimal required httpd version is not
  +satisfied [Pratik <pratiknaik@gmail.com>]
  +
   Fix interactive prompting at perl Makefile.PL, when no APXS or
   MP_AP_PREFIX were provided. now asking for an alternative location if
   the suggested choices weren't selected. [Stas]
  
  
  
  1.158     +7 -11     modperl-2.0/Makefile.PL
  
  Index: Makefile.PL
  ===================================================================
  RCS file: /home/cvs/modperl-2.0/Makefile.PL,v
  retrieving revision 1.157
  retrieving revision 1.158
  diff -u -u -r1.157 -r1.158
  --- Makefile.PL	27 Aug 2004 01:34:29 -0000	1.157
  +++ Makefile.PL	6 Sep 2004 15:52:28 -0000	1.158
  @@ -6,8 +6,8 @@
   # directly or via the top level Makefile.PL
   $ENV{MOD_PERL_2_BUILD} = 1;
   
  -my $min_httpd_version = '2.0.47';
  -my $min_httpd_version_static = '2.0.51';
  +use constant MIN_HTTPD_VERSION_DYNAMIC => '2.0.47';
  +use constant MIN_HTTPD_VERSION_STATIC  => '2.0.51';
   
   my($old_modperl_version, $old_modperl_pm);
   
  @@ -196,6 +196,10 @@
   
       system_sanity_check();
   
  +    my $min_httpd_version = $build->should_build_apache
  +        ? MIN_HTTPD_VERSION_STATIC
  +        : MIN_HTTPD_VERSION_DYNAMIC;
  +
       if ($build->{MP_APXS}) {
           debug "Using APXS => $build->{MP_APXS}";
       }
  @@ -244,15 +248,7 @@
           exit(1);
       }
   
  -    my $min_version;
  -    if ($build->should_build_apache) {
  -        $min_version = $min_httpd_version_static;
  -    }
  -    else {
  -        $min_version = $min_httpd_version;
  -    }
  -    
  -    if ($httpd_version lt $min_version) {
  +    if ($httpd_version lt $min_httpd_version) {
           error "Apache/$httpd_version not supported, " .
                 "$min_httpd_version or higher is required";
           exit(1);
  
  
  

Mime
View raw message