perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject cvs commit: modperl-2.0 INSTALL
Date Sat, 07 Aug 2004 00:18:40 GMT
stas        2004/08/06 17:18:40

  Modified:    .        INSTALL
  Log:
  shrink INSTALL to the very minimum and suggest to read real docs
  otherwise one needs to keep maintain than one document, as users ask to
  add things to INSTALL
  
  Revision  Changes    Path
  1.7       +19 -18    modperl-2.0/INSTALL
  
  Index: INSTALL
  ===================================================================
  RCS file: /home/cvs/modperl-2.0/INSTALL,v
  retrieving revision 1.6
  retrieving revision 1.7
  diff -u -u -r1.6 -r1.7
  --- INSTALL	29 Aug 2003 18:29:44 -0000	1.6
  +++ INSTALL	7 Aug 2004 00:18:40 -0000	1.7
  @@ -1,29 +1,30 @@
   Simple install:
   
  -% perl Makefile.PL MP_APXS=/usr/local/apache2/bin/apxs
  -% make && make test
  -% make install
  -
  -If Apache was built but not installed yet or if apxs is not available
  -and Apache was installed under a single tree (e.g.,
  -/usr/local/apache2), you should use the MP_AP_PREFIX option, which
  -points that the Apache tree:
  +  % perl Makefile.PL MP_APXS=/usr/local/apache2/bin/apxs
  +  % make && make test
  +  % make install
   
  -% perl Makefile.PL MP_AP_PREFIX=/usr/local/apache2
  +Simple config:
   
  -See docs/user/install/install.pod for details.
  +  LoadModule perl_module modules/mod_perl.so
  +  PerlModule Apache2
  +  #PerlModule Apache::compat
  +  # your config comes here
   
  -Simple config:
  +For a more detailed version (including more options) refer to:
  +
  +  docs/user/intro/start_fast.pod
   
  -LoadModule perl_module modules/mod_perl.so
  +or online:
   
  -If the MP_INST_APACHE2=1 option was given to Makefile.PL, you'll want
  -to configure:
  +  http://perl.apache.org/docs/2.0/user/intro/start_fast.html
   
  -PerlModule Apache2
  +For an even more detailed documentation refer to:
   
  -For compat with the 1.x version, you'll want to configure:
  +  docs/user/install/install.pod
  +  docs/user/config/config.pod
   
  -PerlModule Apache::compat
  +or online:
   
  -See docs/user/config/config.pod for details.
  +  http://perl.apache.org/docs/2.0/user/install/install.pod
  +  http://perl.apache.org/docs/2.0/user/config/config.pod
  
  
  

Mime
View raw message