perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@apache.org
Subject cvs commit: modperl-2.0 Makefile.PL Changes
Date Thu, 15 Jul 2004 05:40:14 GMT
stas        2004/07/14 22:40:14

  Modified:    .        Makefile.PL Changes
  Log:
  require Perl 5.6.1, 5.6.0 isn't supported for a long time, but we
  weren't aborting at the Makefile.PL stage
  
  Revision  Changes    Path
  1.145     +2 -2      modperl-2.0/Makefile.PL
  
  Index: Makefile.PL
  ===================================================================
  RCS file: /home/cvs/modperl-2.0/Makefile.PL,v
  retrieving revision 1.144
  retrieving revision 1.145
  diff -u -u -r1.144 -r1.145
  --- Makefile.PL	15 Jul 2004 05:37:51 -0000	1.144
  +++ Makefile.PL	15 Jul 2004 05:40:14 -0000	1.145
  @@ -392,8 +392,8 @@
       }
   
       if ($] < 5.006_001) {
  -        error "$perl_string.",
  -            "We strongly suggest you upgrade it to at least 5.6.1";
  +        error "$perl_string. You need at least Perl 5.6.1";
  +        exit 1;
       }
   
       if ($] >= 5.007 and $] < 5.008) {
  
  
  
  1.412     +3 -0      modperl-2.0/Changes
  
  Index: Changes
  ===================================================================
  RCS file: /home/cvs/modperl-2.0/Changes,v
  retrieving revision 1.411
  retrieving revision 1.412
  diff -u -u -r1.411 -r1.412
  --- Changes	14 Jul 2004 07:27:00 -0000	1.411
  +++ Changes	15 Jul 2004 05:40:14 -0000	1.412
  @@ -12,6 +12,9 @@
   
   =item 1.99_15-dev
   
  +require Perl 5.6.1, 5.6.0 isn't supported for a long time, but we
  +weren't aborting at the Makefile.PL stage [Stas]
  +
   Apache::RequestUtil::method_register($s->process->pconf, 'FOO'); is
   now $s->method_register('FOO') [Stas]
   
  
  
  

Mime
View raw message