perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From do...@locus.apache.org
Subject cvs commit: modperl/src/modules/perl mod_perl.c
Date Thu, 30 Mar 2000 00:20:35 GMT
dougm       00/03/29 16:20:35

  Modified:    .        Changes
               src/modules/perl mod_perl.c
  Log:
  change $Apache::VERSION check to use a string instead of SvNV
  
  Revision  Changes    Path
  1.444     +3 -0      modperl/Changes
  
  Index: Changes
  ===================================================================
  RCS file: /home/cvs/modperl/Changes,v
  retrieving revision 1.443
  retrieving revision 1.444
  diff -u -r1.443 -r1.444
  --- Changes	2000/03/26 20:32:53	1.443
  +++ Changes	2000/03/30 00:20:32	1.444
  @@ -10,6 +10,9 @@
   
   =item 1.22_01-dev
   
  +change $Apache::VERSION check to use a string instead of SvNV, which
  +was troublesome with Perl 5.6.0, thanks to Dave Seidel for pinpointing
  +
   Apache::src fixup to quiet warnings under Perl 5.004. Thanks to Ken
   Williams for the spot. [ Ask Bjoern Hansen ]
   
  
  
  
  1.109     +5 -4      modperl/src/modules/perl/mod_perl.c
  
  Index: mod_perl.c
  ===================================================================
  RCS file: /home/cvs/modperl/src/modules/perl/mod_perl.c,v
  retrieving revision 1.108
  retrieving revision 1.109
  diff -u -r1.108 -r1.109
  --- mod_perl.c	2000/03/23 05:56:10	1.108
  +++ mod_perl.c	2000/03/30 00:20:34	1.109
  @@ -523,24 +523,25 @@
       if(!PERL_IS_DSO) \
           register_cleanup(p, NULL, mp_server_notstarting, mod_perl_noop) 
   
  -#define MP_APACHE_VERSION 1.26
  +#define MP_APACHE_VERSION "1.26"
   
   void mp_check_version(void)
   {
       I32 i;
       SV *namesv;
       SV *version;
  +    STRLEN n_a;
   
       require_Apache(NULL);
   
       if(!(version = perl_get_sv("Apache::VERSION", FALSE)))
   	croak("Apache.pm failed to load!"); /*should never happen*/
  -    if(SvNV(version) >= MP_APACHE_VERSION) /*no worries*/
  +    if(strEQ(SvPV(version,n_a), MP_APACHE_VERSION)) /*no worries*/
   	return;
   
  -    fprintf(stderr, "Apache.pm version %.02f or higher required!\n", 
  +    fprintf(stderr, "Apache.pm version %.02f required!\n", 
   	    MP_APACHE_VERSION);
  -    fprintf(stderr, "%s", form("%_ is only version %_\n", 
  +    fprintf(stderr, "%s", form("%_ is version %_\n", 
   			       *hv_fetch(GvHV(incgv), "Apache.pm", 9, FALSE),
   			       version));
       fprintf(stderr, 
  
  
  

Mime
View raw message