perl-modperl-cvs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Cholet <cho...@logilune.com>
Subject RE: cvs commit: modperl Changes ToDo
Date Fri, 10 Sep 1999 19:43:00 GMT
On Friday, September 10, 1999 9:28 PM, Ask Bjoern Hansen [SMTP:ask@valueclick.com] wrote:
> On 9 Sep 1999 cholet@hyperreal.org wrote:
> 
> > cholet      99/09/09 04:48:27
> > 
> >   Modified:    src/modules/ApacheModulePerl ApacheModulePerl.dsp
> >                .        Changes ToDo
> >   Log:
> >   apache 1.3.7+ uses Winsock2
> 
> So now we only support 1.3.9+ on Windows, no? If that's the case it should
> be noted in the Changes file.

Hmmm, right. Apache 1.3.7+ supports only Winsock 2, so without this patch
mod_perl won't build with 1.3.9, but with it it won't build with older versions.
In unix-land this could be dealt with since the makefile is generated, but here
with a static .dsp I guess it isn't possible?
In that case maybe Changes should borrow from Apache's:

  *) Win32: Update the server to use Winsock 2. Specifically, link with
     ws2_32.lib rather than wsock32.lib.  This gives us access to 
     WSADuplcateSocket() in addition to some other enhanced comm APIs.
     Win 95 users may need to update their TCP/IP stack to pick up
     Winsock 2. (See http://www.microsoft.com/windows95/downloads/)
     [Bill Stoddard stoddard@raleigh.ibm.com]

>  - ask
> 
> -- 
> ask bjoern hansen - <http://www.netcetera.dk/~ask/>
> more than 40M impressions per day, <http://valueclick.com>
> 

--
Eric


Mime
View raw message