perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerald Richter - ECOS <rich...@ecos.de>
Subject AW: Problem with "last" label
Date Fri, 10 Jan 2014 07:58:04 GMT
Hi Andreas,

 
could you send me you httpd.conf (at least the part with the Embperl/mod_perl configuration)?

 
Regards

 
Gerald

 
 
Von: Andreas Rieke [mailto:andreas.rieke@isl.de] 
Gesendet: Donnerstag, 9. Januar 2014 19:16
An: Gerald Richter; embperl@perl.apache.org
Cc: kt@isl.de
Betreff: Re: Problem with "last" label

 
Hi Gerald,

sorry, but we did not manage to configure what you have asked for in the httpd.conf (Apache
2.2).

EMBPERL_DEBUG 0x7fffffff
Invalid command 'EMBPERL_DEBUG', perhaps misspelled or defined by a module not included in
the server configuration

SetEnv EMBPERL_DEBUG 0x7fffffff
PerlSetEnv EMBPERL_DEBUG 0x7fffffff
No change, even after restart of apache. There is also no log file in /tmp.

After searching for the keywords with Google, we also tested the following commands directly
in the epl file:
$application -> config -> debug (0x7fffffff);
or
$component -> config -> debug (0x7fffffff);
However, in both cases we received "Error in Perl code: Can't call method "config" on an undefined
value"

What are we doing wrong?

Thanks in advance and best regards,

Andreas




Am 08.01.2014 15:07, schrieb Gerald Richter - ECOS:

Hi Andreas,

 
sorry for the late reply.

 
Can you set EMBPERL_DEBUG in the httpd.conf to 0x7fffffff (and maybe EMBPERL_LOG) and send
me the embperl.log (by default /tmp/embperl.log) for that example file?

 
Thanks & Regards

 
Gerald

 
 
Von: Andreas Rieke [mailto:andreas.rieke@isl.de <mailto:andreas.rieke@isl.de> ] 
Gesendet: Mittwoch, 1. Januar 2014 11:38
An: Gerald Richter; embperl@perl.apache.org <mailto:embperl@perl.apache.org> 
Betreff: Re: Problem with "last" label

 
Good morning Gerald,

we use perl 5.16.3 on our production machines and try 5.18.1 in the development area - we
expect that the development of perl 5.16 will stop sometime this year, and for that reason,
we are already trying the new version.

I hope that the file which I have attached to this email will help - it is the shortest from
the 5 candidates and hopefully the most simple one. I did not change anything within this
file - according to the apache log file the error happens in line 80. This is the complete
error log:
error.13-12.log:[Tue Dec 29 15:48:02 2013] [error] [16539]ERR:  24:  Error in Perl code:
Label not found for "last l9" at /opt/apache/htdocs/management/admin/user2accessgroup.epl
line 80.

Please let me know if I can do anything to assist finding the error; I work with apache, perl,
mod_perl and embperl for certainly 8 years not, but I am not an embperl insider,

Best regards,

Andreas




Am 31.12.2013 17:01, schrieb Gerald Richter - ECOS:

Hi Andreas,

 
this looks like an Embperl problem, but I didnt seen it before (I am still using Perl 5.16
not Perl 5.18).

 
Do you have a short test file that you can send me, so I can reproduce the error here?

 
Gerald

 
 
Von: Andreas Rieke [mailto:andreas.rieke@isl.de <mailto:andreas.rieke@isl.de> ] 
Gesendet: Sonntag, 29. Dezember 2013 17:24
An: embperl@perl.apache.org <mailto:embperl@perl.apache.org> 
Betreff: Problem with "last" label

 
Hi,

we have a strange problem with labels which only occurs when compiling embperl with perl 5.18.1;
with perl 5.16.3, everything works well. Unfortunately, the problem seems to happen with a
certain probability; sometimes, things work well, but sometime else, we get the following
message in the apache logs and an internal server error in the browser:

Error in Perl code: Label not found for "last l9" at /opt/apache/htdocs/management/admin/user2accessgroup.epl
line 80.

We are working with CentOS 5.10 on 32 and 64 bit machines. We use apache 2.2.25 with mod_perl
2.0.8 and embperl 2.5.0_4. The error happens only with 5 of the (certainly) 100 epl files
we are working with; I just checked the shortest file by hand, there are no syntax errors
in it.
When looking for the file and the line from the logs, there is nothing strange at that position;
the 5 files do not even contain a "last" statement.

Is this an embperl issue? If not, is it a mod_perl problem?
Did anybody else see a similar problem?
What can I do to get more information about it or to solve the problem?

Best regards,

Andreas Rieke

-- 
Dr. Ing. Andreas Rieke
- Geschftsfhrender Gesellschafter -






   ISL Internet Sicherheitslsungen GmbH
   Bergstrasse 128 
   D-58095 Hagen

   Tel.: +49 (0) 2331/34956-0
   Fax.: +49 (0) 2331/34956-29
   E-Mail: andreas.rieke@isl.de <mailto:andreas.rieke@isl.de> 
   Website: www.isl.de <http://www.arp-guard.com> 
   Website: www.arp-guard.com <http://www.arp-guard.com> 


Geschftsfhrer: Dr.-Ing. Andreas Rieke | Sitz: Hagen
HRB 3816 | Amtsgericht Hagen | UStID-Nr. DE 201547313

 
 
-- 
Dr. Ing. Andreas Rieke
- Geschftsfhrender Gesellschafter -





   ISL Internet Sicherheitslsungen GmbH
   Bergstrasse 128 
   D-58095 Hagen

   Tel.: +49 (0) 2331/34956-0
   Fax.: +49 (0) 2331/34956-29
   E-Mail: andreas.rieke@isl.de <mailto:andreas.rieke@isl.de> 
   Website: www.isl.de <http://www.arp-guard.com> 
   Website: www.arp-guard.com <http://www.arp-guard.com> 


Geschftsfhrer: Dr.-Ing. Andreas Rieke | Sitz: Hagen
HRB 3816 | Amtsgericht Hagen | UStID-Nr. DE 201547313

 

 

 

---------------------------------------------------------------------


 

To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org <mailto:embperl-unsubscribe@perl.apache.org>



 

For additional commands, e-mail: embperl-help@perl.apache.org <mailto:embperl-help@perl.apache.org>


 
-- 
Dr. Ing. Andreas Rieke
- Geschftsfhrender Gesellschafter -




   ISL Internet Sicherheitslsungen GmbH
   Bergstrasse 128 
   D-58095 Hagen

   Tel.: +49 (0) 2331/34956-0
   Fax.: +49 (0) 2331/34956-29
   E-Mail: andreas.rieke@isl.de <mailto:andreas.rieke@isl.de> 
   Website: www.isl.de <http://www.arp-guard.com> 
   Website: www.arp-guard.com <http://www.arp-guard.com> 


Geschftsfhrer: Dr.-Ing. Andreas Rieke | Sitz: Hagen
HRB 3816 | Amtsgericht Hagen | UStID-Nr. DE 201547313

 

Mime
View raw message