perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Rieke <andreas.ri...@isl.de>
Subject Problem with "last" label
Date Sun, 29 Dec 2013 16:23:32 GMT
Hi,

we have a strange problem with labels which only occurs when compiling 
embperl with perl 5.18.1; with perl 5.16.3, everything works well. 
Unfortunately, the problem seems to happen with a certain probability; 
sometimes, things work well, but sometime else, we get the following 
message in the apache logs and an internal server error in the browser:

Error in Perl code: Label not found for "last l9" at 
/opt/apache/htdocs/management/admin/user2accessgroup.epl line 80.

We are working with CentOS 5.10 on 32 and 64 bit machines. We use apache 
2.2.25 with mod_perl 2.0.8 and embperl 2.5.0_4. The error happens only 
with 5 of the (certainly) 100 epl files we are working with; I just 
checked the shortest file by hand, there are no syntax errors in it.
When looking for the file and the line from the logs, there is nothing 
strange at that position; the 5 files do not even contain a "last" 
statement.

Is this an embperl issue? If not, is it a mod_perl problem?
Did anybody else see a similar problem?
What can I do to get more information about it or to solve the problem?

Best regards,

Andreas Rieke

-- 
Dr. Ing. Andreas Rieke
- Geschäftsführender Gesellschafter -

signatur_oben
ISL Internet Sicherheitslösungen GmbH
    Bergstrasse 128
    D-58095 Hagen

    Tel.: +49 (0) 2331/34956-0
    Fax.: +49 (0) 2331/34956-29
    E-Mail: andreas.rieke@isl.de <mailto:andreas.rieke@isl.de>
    Website: www.isl.de <http://www.arp-guard.com>
    Website: www.arp-guard.com <http://www.arp-guard.com>
signatur_unten


Geschäftsführer: Dr.-Ing. Andreas Rieke | Sitz: Hagen
HRB 3816 | Amtsgericht Hagen | UStID-Nr. DE 201547313


Mime
View raw message