perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Gunton <n...@nilspace.com>
Subject Re: Compilation error
Date Sat, 10 Nov 2012 17:18:27 GMT
Hi Gerald, yes! I think that fixed it. Well done, and thanks as always 
for your help.

:-)

Neil

richter@ecos.de wrote:
> Hi Neil,
>
> please check if http://www.embperl.org/downloads/Embperl-2.5.0_3.tar.gz fixes your problem
>
> Gerald
>
>
>> -----Original Message-----
>> From: Neil Gunton [mailto:neil@nilspace.com]
>> Sent: Saturday, October 13, 2012 8:42 PM
>> To: Gerald Richter - ECOS
>> Cc: embperl@perl.apache.org
>> Subject: Re: Compilation error
>>
>> I think I have found what makes the problem happen. It occurs in a .epl
>> subroutine file where I have 'use strict' at the start, and then within a [! !]
>> block, there is a perl sub where I introduce a variable without using 'my', e.g.
>>
>> [!
>> use strict;
>> sub test
>> {
>>      $x = 1;
>> }
>> !]
>>
>> The problem does not manifest if I do the same thing in an index.html
>> within a [- -] block, i.e.
>>
>> [-
>> use strict;
>> $x = 1;
>> -]
>>
>> ... in that case, I get a more helpful error message:
>>
>> [32570]ERR: 24: Error in Perl code: Global symbol "$x" requires explicit
>> package name at
>> /www-dev/vhosts/crazyguyonabike.com/htdocs/test/index.html line 3.
>>
>> I'm not sure if there are other factors in the way my codebase is
>> constructed which contribute to this error not getting reported
>> correctly. Before I dig too much more deeply, does the above give you
>> enough clues to try reproducing on your end, Gerald?
>>
>> Thanks again for your help,
>>
>> Neil
>>
>> richter@ecos.de wrote:
>>> This is strange. The problem has definitively gone for me in2.5.0 _2 with
>> perl 5.14.
>>>
>>> Does make test (without any options) succeed?
>>>
>>> Gerald
>>>
>>>
>>>> -----Original Message-----
>>>> From: Neil Gunton [mailto:neil@nilspace.com]
>>>> Sent: Saturday, October 13, 2012 1:37 AM
>>>> To: embperl@perl.apache.org
>>>> Subject: Compilation error
>>>>
>>>> I am still getting this problem with the latest version of Embperl (2.5).
This
>> is
>>>> on Debian Wheezy (testing), Perl 5.14. I have made a number of changes
>> in
>>>> my code, and when I try to access my development website I just get this:
>>>>
>>>> Internal Server Error
>>>> The server encountered an internal error or misconfiguration and was
>> unable
>>>> to complete your request.
>>>>
>>>> Please contact the server administrator, neil@nilspace.com and inform
>> them
>>>> of the time the error occurred, and anything you might have done that
>> may
>>>> have caused the error.
>>>>
>>>> [17349]ERR: 24: Error in Perl code: Compilation error
>>>>
>>>> Apache Embperl 2.5.0_2 [Fri Oct 12 16:34:56 2012]
>>>>
>>>> This is obviously really unhelpful and makes it impossible to even begin
to
>>>> find out where the error is. Any ideas?
>>>>
>>>> Thanks,
>>>>
>>>> Neil
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
>>>> For additional commands, e-mail: embperl-help@perl.apache.org
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
>>> For additional commands, e-mail: embperl-help@perl.apache.org
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
>> For additional commands, e-mail: embperl-help@perl.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message