perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rich...@ecos.de
Subject RE: Installing Embperl 2.4 on Debian Squeeze / Embperl 2.5 development snapshot for Perl 5.14
Date Tue, 27 Mar 2012 17:49:15 GMT
Sorry, my fault. These are debug messages I missed to remove.

Go into the file epinit.c, search for fprintf with these messages and delete the lines.

After that make test should run better.

Gerald


> -----Original Message-----
> From: Neil Gunton [mailto:neil@nilspace.com]
> Sent: Tuesday, March 27, 2012 6:40 PM
> To: Gerald Richter - ECOS
> Cc: embperl@perl.apache.org
> Subject: Re: Installing Embperl 2.4 on Debian Squeeze / Embperl 2.5
> development snapshot for Perl 5.14
> 
> richter@ecos.de wrote:
> > Hi,
> >
> > the Bug [1] is fixed in my current development version, this also fixes the
> other tests. The only thing that is still not working is the automatic reload of
> changed files, because Perl 5.14 prohibits the redefinition of sub's.
> >
> > I have put a snapshot of my current development version on
> >
> > http://www.embperl.org/downloads/Embperl-2.5.0_1.tar.gz
> >
> > This one runs fine with Perl 5.14.
> >
> > In case somebody is using Embperl::Form, there are a lot of
> > incompatible changes since 2.4, because I have moved from Prototype to
> > jQuery
> 
> Hi Gerald, I downloaded your snapshot from above, and 'Perl Makefile.PL'
> and 'make' both go without problem.
> 
> However, 'make test' still fails for me. This is on Debian Wheezy, Perl
> 5.14 stock build. Output follows:
> 
> root@dev:/usr/src/Embperl-2.5.0_1# make test
> make[1]: Entering directory `/usr/src/Embperl-2.5.0_1/xs'
> make[2]: Entering directory `/usr/src/Embperl-2.5.0_1/xs/Embperl'
> make[3]: Entering directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/App'
> make[4]: Entering directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/App/Config'
> make[4]: Leaving directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/App/Config'
> make[3]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/App'
> make[3]: Entering directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Component'
> make[4]: Entering directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Config'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Config'
> make[4]: Entering directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Output'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Output'
> make[4]: Entering directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Param'
> make[4]: Leaving directory
> `/usr/src/Embperl-2.5.0_1/xs/Embperl/Component/Param'
> make[3]: Leaving directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Component'
> make[3]: Entering directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Req'
> make[4]: Entering directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Req/Config'
> make[4]: Leaving directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Req/Config'
> make[4]: Entering directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Req/Param'
> make[4]: Leaving directory `/usr/src/Embperl-
> 2.5.0_1/xs/Embperl/Req/Param'
> make[3]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Req'
> make[3]: Entering directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Syntax'
> make[3]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Syntax'
> make[3]: Entering directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Thread'
> make[3]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs/Embperl/Thread'
> make[2]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs/Embperl'
> make[1]: Leaving directory `/usr/src/Embperl-2.5.0_1/xs'
> PERL_DL_NONLAZY=0 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
> 
> loading...                    ok
> 
> Testing offline mode...
> 
> #0 ascii...
> 
> [-1]embperl_InitRequest
> [-2]embperl_CleanupRequest
> [-3]embperl_CleanupComponent
> [-4]embperl_CleanupOutput
> [-5]embperl_CleanupOutput done
> [-6]embperl_CleanupComponent done
> [-7]embperl_CleanupRequest done
> 
> 
>   ERRORS detected! NOT all tests have been passed successfully
> 
> cat: test/tmp/httpd.pid: No such file or directory
> make: *** [test_dynamic] Error 1
> root@dev:/usr/src/Embperl-2.5.0_1#
> 
> Could this be related to the fact that I build two versions of apache on my
> system, httpd_perl and httpd_proxy, so the resulting files used by
> httpd_perl may be different from normal (e.g. the pid file, your script looks
> for 'httpd.pid', my apache build might use something different like
> 'httpd_perl.pid, but I'm not sure about that)? Is there some way to work
> around this on my end (i.e. specify what it will be called) or else does it have
> to be something that the Embperl make test script detects?
> 
> Thanks again,
> 
> Neil


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message