perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Gunton <n...@nilspace.com>
Subject Re: Installing Embperl 2.4 on Debian Squeeze / Embperl 2.5 development snapshot for Perl 5.14
Date Wed, 28 Mar 2012 17:33:50 GMT
Neil Gunton wrote:
> richter@ecos.de wrote:
>> Apache2::ServeRec i spart of mod_perl 2 and should be already
>> installed, if mod_perl is installed.
>> Of course you have to figure out why Apache2::ServerRec is missing on
>> your System
>
> I found it installed under
>
> /root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi/Apache2/ServerRec.pm
>
> This is weird, but consistent - if you recall my original message in
> this thread, Embperl 2.4 was installing itself under /root/perl5 too. Do
> you have any clues as to what affects this behavior? I assume it's just
> some environment variable that isn't set right...

Update: I found the following had been tacked onto the end of /root/.bashrc:

export PERL_LOCAL_LIB_ROOT="/root/perl5";
export PERL_MB_OPT="--install_base /root/perl5";
export PERL_MM_OPT="INSTALL_BASE=/root/perl5";
export 
PERL5LIB="/root/perl5/lib/perl5/x86_64-linux-gnu-thread-multi:/root/perl5/lib/perl5";
export PATH="/root/perl5/bin:$PATH";

I didn't put this there, so some package in Debian Wheezy must have done 
it. It's obviously messing with the installation of Perl modules, since 
once they get put under /root then other modules can't find them. So 
whatever added those lines obviously didn't also add that path to the 
other places where it seems to be needed. So I tried commenting those 
lines out of .bashrc, rebuilt mod_perl, and then Embperl (2.5.0), and it 
all seems to complete and install properly now.

Off topic a bit: I was a bit surprised to find out that some fairly 
major things seem to be broken in Debian Wheezy. For example, cups - I 
just get blank pages when I print to my Brother laser printer. 
Eventually I found this thread:

https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/950713

I reset the printer type to be the most basic generic printer, and now I 
can at least print pages, but not access any of the options of the printer.

I don't know, I guess I was expecting Wheezy to be a bit more stable at 
this point, given that they are intending to go into freeze in June 2012:

http://stevenrosenberg.net/blog/linux/debian/2011_0809_debian

Hope things settle down soon... I went to Wheezy primarily because I 
wanted to use an SSD for my workstation (to cut down on disk drive hum 
and increase performance for the root filesystem). For SSD to work 
efficiently (i.e. enable TRIM), you need a more recent kernel than 
Squeeze. When I tried installing the backport kernel, things didn't seem 
to work well (can't remember what broke, but something did). So I 
decided to just try a new Wheeze install. It seems to work, mostly, but 
now I am finding files are just going missing without any disk errors... 
and this isn't even on the SSD, it's on my big data hard drive, which is 
a regular WD drive. No disk errors, files just seem to disappear 
randomly. I'm returning the drive to get another one, but part of me 
wonders if it's actually the drive, or this new kernel, or some bug in 
ext4 etc. What fun.

Anyway, thanks again for the help.

Neil

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message