perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerard <gsara...@rarcoa.com>
Subject embperl 2.3.0 make test fails ascii test?
Date Mon, 13 Sep 2010 22:22:14 GMT
  Hi everyone,
I somehow managed to break some part of my perl installation while 
upgrading it, and now 'make test' with Embperl fails even the most basic 
ascii test:
[-1][2667]ERR:  24:  Error in Perl code: syntax error at 
/root/Embperl-2.3.0/test/html/ascii line 3, at EOF
[-2]syntax error at /root/Embperl-2.3.0/test/html/ascii line 11, near ";
[-3]]"

Normally I have something to go on, but I don't even know where to start 
with this one, it's finding errors in the ascii file on lines that 
aren't even there, here's the top 12 lines from the file:
---- ./test/cmp/ascii
Just a litle text ...

Nothing here to say ...

No HTML tags ...

Just ASCII ...

And once again ...

Just a litle text ...

----

I don't know where it got the ; on line 11 from?

I didn't want to make this email any bigger by attaching the test.log 
file, so you can download it here:
http://rarcoa.com/embperl/test.log (74kb)

my system comes with a handy script called 'perl-cleaner' which 
basically rebuilds all perl related modules, so I ran that, and 
reinstalled mod_perl etc., but still no go with Embperl, there has to be 
some leftover bit from the old perl version, I just don't know where to 
look now.
ps. my old perl version was 5.10.1, and now I'm using 5.12.2

so any pointers would be appreciated,
Thanks!

-- 
Gerard Saraber


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message