perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stevens <michael.stev...@dianomi.com>
Subject Re: Embperl BETA 2.4.0 is available
Date Thu, 01 Jul 2010 15:55:24 GMT
Gerald,

It would be great to have a new release of Embperl, how's 2.4 going?

On 19/03/10 05:44, Gerald Richter - ECOS wrote:
> Hi,
>
> after a very long time of I am very happy to announce the next beta release of Embperl.
>
> It is available for download and testing at
>
> http://www.embperl.org/downloads/Embperl-2.4.0_2.tar.gz
>
> It would be great if you can test it out, especially on different distributions using
Perl, Apache and mod_perl provided by the Distribution. It's already working out of the box
with openSuSE 11.2, but it would be great if somebody could test it on Debian, RetHat etc.
and give me feedback.
>
> Also I started an example for Embperl::Form, since I believe it's a very usefull addon,
but it is not documented yet. Look at eg/forms/README.txt. For now the example does not show
the full power of Embperl::Form, like the Ajax stuff, datepicker, RichText edit and so one,
but it might be helpful to understand the basics.
>
> If somebody else also think this is a usefull tool, help with creating more examples
and documentation would be very much appreciated.
>
> Overall documentation is not updated yet.
>
> As always questions, feedback and patches are welcome
>
> Regards
>
> Gerald
>
> Changes since 2.3.0:
>
>      - Support for CGI.pm 3.43 (included within Perl 5.10.1)
>        for file uplaods. CGI.pm<  2.43 is not supported anymore.
>      - A lot of enhancements for Embperl::Form
>      - Add example for usage of Embperl::Form. See
>        eg/forms/README.txt. Can be viewed used using "make start"
>      - Increased size limit for errormessage from 1024 to 4096
>      - Makefile.PL can now handle compiling 32Bit code on 64Bit
>        sytsem if Perl was compiled as 32Bit application
>      - Adaption of tests to changed error messages of perl 5.10
>      - Makefile.PL can now cope with OpenSuSE 11.2, if perl,
>        mod_perl and apache are installed from OpenSuSE packages.
>      - Fix make test error for Perl compiled with DEBUGGING on
>      - Support for internationalization in Emberl::Form
>      - Do not link against unused libz
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
>


-- 
Michael Stevens
Dianomi Ltd
18 Buckingham Gate
London SW1E 6LB

Tel: 020 7802 5530
Fax: 020 7630 7356
www.dianomi.com

The information in this message and any attachment is intended for the 
addressee and is confidential and may be subject to legal privilege. 
Dianomi Ltd, Registered Office: One America Square, Crosswall, London. 
EC3N 2SG. Registered in England and Wales with Company Registration 
Number 4513809. VAT registration number: 809754988

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message