perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerald Richter - ECOS <gerald.rich...@ecos.de>
Subject RE: Embperl BETA 2.4.0 is available
Date Mon, 19 Apr 2010 06:29:41 GMT
I suggest setting EMBPERL_LOG to -1 and take a look at the embperl.log file. That might shed
some light what is going on here

 

Gerald

 

 

From: Marcus Doemling [mailto:md7852@hotmail.com] 
Sent: Monday, April 19, 2010 1:34 AM
To: embperl@perl.apache.org
Subject: RE: Embperl BETA 2.4.0 is available



 

I think there is another issue on the Mac. It seems I cannot get it to recognize the configuration
parameters in httpd.conf on the Mac. My conf is as follows:

  LoadModule perl_module libexec/apache2/mod_perl.so
  LoadModule embperl_module libexec/apache2/Embperl.so

  PerlModule Embperl
  AddType text/html .bhtml

  <Files *.bhtml>
        Embperl_AppName n1
        Embperl_Object_Base base.bhtml

        SetHandler perl-script
        PerlHandler Embperl::Object
        Options ExecCGI
  </Files>

It will not recognize Embperl_Object_Base or any other embperl setting. I have tried is also
with the environmental variables using Embperl_UseEnv. When starting httpd with the -D EMBPERL_APDEBUG
options I get this:

  [Sun Apr 18 16:27:38 2010] [warn] EmbperlDebug: create_server_config (0xbogus %p [3732/0]\n
  [Sun Apr 18 16:27:38 2010] [warn] EmbperlDebug: create_dir_config Embperl (0xbogus %p [3732/0]\n
  [Sun Apr 18 16:27:38 2010] [warn] EmbperlDebug: create_dir_config Embperl (0xbogus %p [3732/0]\n
  [Sun Apr 18 16:27:38 2010] [warn] EmbperlDebug: Set APPNAME (type=char *;STR) = n1\n
  [Sun Apr 18 16:27:38 2010] [warn] EmbperlDebug: Set OBJECT_BASE (type=char *;STR) = base.bhtml\n

But when accessing a page I get the error:

  [Sun Apr 18 16:29:04 2010] [error] [3664]ERR:  404: : Not found '_base.epl', searched:

  [Sun Apr 18 16:29:04 2010] [error] Embperl::Object base _base.epl not found. Searched '/Users/marcus/web/test
/Users/marcus/web' and ''

However make test TESTARGS="-h" runs successfully. I'm out of ideas.

Thanks,
Marcus


The New Busy is not the too busy. Combine all your e-mail accounts with Hotmail. Get busy.



Mime
View raw message