perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Doemling <md7...@hotmail.com>
Subject RE: Embperl BETA 2.4.0 is available
Date Tue, 20 Apr 2010 04:02:22 GMT

Ok I found something and this is strange.

If I replace

  
LoadModule embperl_module libexec/apache2/Embperl.so

with

 
 LoadModule embperl_module 
"/Users/marcus/src/Embperl-2.4.0_2/blib/arch/auto/Embperl/Embperl.bundle"

then
 the embperl configuration settings are honored.

To dig into this
 I tried every variation related to the Embperl.bundle file that I could
 come up with. First of all the two files Embperl.so and Embperl.bundle 
are identical. I made the modes, ownership for file and parent directory
 identical but the first LoadModule directive above still causes the 
embperl configurations not to be honored. I tried using an absolute 
path, I also tried changing the file extension in the second LoadModule 
directive above from .bundle to .so and also this causes the problem. 
Also the file location into which "make install" is moving it (/Library/Perl/5.10.0/darwin-thread-multi-2level/auto/Embperl/Embperl.bundle)
 does not work.

In summary if I use a relocated file the problem 
will occur.

Thanks,
Marcus 		 	   		  
_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2
Mime
View raw message