perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerald Richter - ECOS <gerald.rich...@ecos.de>
Subject RE: Embperl BETA 2.4.0 is available
Date Sat, 20 Mar 2010 14:38:19 GMT
Hi,

could you please try if the following patch solves the problem?

--- test.pl     (revision 925098)
+++ test.pl     (working copy)
@@ -1756,6 +1756,7 @@
            !($_ =~ /SES\:/) &&
            !($_ =~ /gcache started/) &&
             !($_ =~ /EmbperlDebug: /) &&
+            !($_ =~ /not available until httpd/) &&
             $_ ne 'Use of uninitialized value.')
            {

Gerald



> -----Original Message-----
> From: Aare Vesi [mailto:aare.lists@myrien.com]
> Sent: Friday, March 19, 2010 12:17 PM
> To: Gerald Richter - ECOS
> Cc: embperl@perl.apache.org
> Subject: Re: Embperl BETA 2.4.0 is available
> 
> Hello!
> 
> On 19.03.2010 7:44, Gerald Richter - ECOS wrote:
> > after a very long time of I am very happy to announce the next beta
> release of Embperl.
> > It is available for download and testing at
> > http://www.embperl.org/downloads/Embperl-2.4.0_2.tar.gz
> > It would be great if you can test it out, especially on different
> distributions using Perl, Apache and mod_perl provided by the
> Distribution. It's already working out of the box with openSuSE 11.2,
> but it would be great if somebody could test it on Debian, RetHat etc.
> and give me feedback.
> 
> perl Makefile.PL produces following warning:
> 
> ---
> Checking if your kit is complete...
> Warning: the following files are missing in your kit:
>         eg/forms/Embperl/MyForm
>         eg/forms/Embperl/MyForm/DataSource
> Please inform the author.
> ---
> 
> 
> Apart from that:
> 
> Debian GNU/Linux 5.0, Apache/2.2.9, perl, v5.10.0, mod_perl2 2.000004,
> CGI  3.49
> All tests have been passed successfully!
> 
> Red Hat Enterprise Linux ES release 4 (Nahant Update 8), Apache/2.0.52
> (provided by the distribution) / Apache/2.0.63, perl v5.8.5, mod_perl2
> 2.000004, CGI  3.49
> 
> make test shows following error:
> 
> ---
> Testing mod_perl mode...
> 
> #0 ascii...
> 
> [-1]ap_get_server_description() not available until httpd/2.2.4 falling
> back to ap_get_server_version() at
> /usr/lib/perl5/5.8.5/i386-linux-thread-multi/XSLoader.pm line 92.
> [-2][Fri Mar 19 12:30:12 2010] [warn] Init: Session Cache is not
> configured [hint: SSLSessionCache]
> [-3]ap_get_server_banner() not available until httpd/2.2.4 falling back
> to ap_get_server_version() at
> /usr/lib/perl5/5.8.5/i386-linux-thread-multi/XSLoader.pm line 92.
> [-4]ap_get_server_description() not available until httpd/2.2.4 falling
> back to ap_get_server_version() at
> /usr/lib/perl5/5.8.5/i386-linux-thread-multi/XSLoader.pm line 92.
> 
> Input:          test/html/ascii
> Output:         test/tmp/out.htm
> Log:            test/tmp/test.log
> ---
> 
> This is due to mod_perl2 2.000004 generating additional warning message
> under Apache/2.0.
> 
> with make test TESTARGS="-i" all other tests pass correctly.
> 
> Thank you very much for the new release!
> 
> Regards,
> Aare


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message